diff mbox series

[bug#70261,v3] gnu: Add wsbg.

Message ID 34afd7008886cd2ff6b43dfa5626bf6d8efcf446.1713878047.git.jsubuntuxp@disroot.org
State New
Headers show
Series [bug#70261,v3] gnu: Add wsbg. | expand

Commit Message

James Smith April 23, 2024, 1:14 p.m. UTC
* gnu/packages/wm.scm (wsbg): New variable.

Change-Id: Ia83a7afcbb0879f0f6d604e1d671388a30800265
---
 gnu/packages/wm.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)


base-commit: f6367b69bcc597cfec50bfc8e15d3e286dbd07c3

Comments

Z572 April 24, 2024, 2:39 a.m. UTC | #1
James Smith via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/wm.scm (wsbg): New variable.
>
> Change-Id: Ia83a7afcbb0879f0f6d604e1d671388a30800265
> ---
>  gnu/packages/wm.scm | 25 +++++++++++++++++++++++++
>  1 file changed, 25 insertions(+)
>
> diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
> index 2eecc0ed2a..f2cb77f5bf 100644
> --- a/gnu/packages/wm.scm
> +++ b/gnu/packages/wm.scm
> @@ -70,6 +70,7 @@
>  ;;; Copyright © 2024 Ahmad Draidi <a.r.draidi@redscript.org>
>  ;;; Copyright © 2024 chris <chris@bumblehead.com>
>  ;;; Copyright © 2024 Erik Eduardo Alonso Hernández <erik@erikeduardo.xyz>
> +;;; Copyright © 2024 James Smith <jsubuntuxp@disroot.org>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -3813,6 +3814,30 @@ (define-public velox
>  It is inspired by dwm and xmonad.")
>        (license license:expat))))
>  
> +(define-public wsbg
> +  (let ((commit "15b0d0f6910ea97b9bcc471695fac07270955dd2")
> +        (revision "0")
> +        ;; Upstream has no version tags, but meson.build contains the correct
> +        ;; version number.
> +        (version "0.1.0"))
> +    (package
> +      (inherit swaybg)
> +      (name "wsbg")
> +      (version (git-version version revision commit))
> +      (source
> +       (origin
> +         (method git-fetch)
> +         (uri (git-reference
> +               (url "https://github.com/saibier/wsbg")
> +               (commit commit)))
> +         (file-name (git-file-name name version))
> +         (sha256
> +          (base32 "15xrnwp54kghigx06y4qmmn1q9f26fx4cawyl4kcbqrrzfbbj1g6"))))
> +      (home-page "https://github.com/saibier/wsbg")
> +      (synopsis "Workspace wallpaper tool for Sway")
> +      (description "Wallpaper utility for Sway with support for per-workspace
> +configuration."))))
> +
>  (define-public yambar-wayland
>    (package
>      (name "yambar-wayland")
>
> base-commit: f6367b69bcc597cfec50bfc8e15d3e286dbd07c3

LGTM, push, see https://git.savannah.gnu.org/cgit/guix.git/commit/?id=c58b443102e92fccfbc204769a57757287e41d11
diff mbox series

Patch

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 2eecc0ed2a..f2cb77f5bf 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -70,6 +70,7 @@ 
 ;;; Copyright © 2024 Ahmad Draidi <a.r.draidi@redscript.org>
 ;;; Copyright © 2024 chris <chris@bumblehead.com>
 ;;; Copyright © 2024 Erik Eduardo Alonso Hernández <erik@erikeduardo.xyz>
+;;; Copyright © 2024 James Smith <jsubuntuxp@disroot.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3813,6 +3814,30 @@  (define-public velox
 It is inspired by dwm and xmonad.")
       (license license:expat))))
 
+(define-public wsbg
+  (let ((commit "15b0d0f6910ea97b9bcc471695fac07270955dd2")
+        (revision "0")
+        ;; Upstream has no version tags, but meson.build contains the correct
+        ;; version number.
+        (version "0.1.0"))
+    (package
+      (inherit swaybg)
+      (name "wsbg")
+      (version (git-version version revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/saibier/wsbg")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "15xrnwp54kghigx06y4qmmn1q9f26fx4cawyl4kcbqrrzfbbj1g6"))))
+      (home-page "https://github.com/saibier/wsbg")
+      (synopsis "Workspace wallpaper tool for Sway")
+      (description "Wallpaper utility for Sway with support for per-workspace
+configuration."))))
+
 (define-public yambar-wayland
   (package
     (name "yambar-wayland")