diff mbox series

[bug#71630,4/5] gnu: mingw-w64-tools: Use G-Expressions.

Message ID 344b2e60dc52efd6d6f9a09181f045e2daa50702.1718708756.git.jean@foundation.xyz
State New
Headers show
Series gnu: make-mingw-w64: Update to 12.0.0. | expand

Commit Message

Jean-Pierre De Jesus DIAZ June 18, 2024, 11:26 a.m. UTC
* gnu/packages/mingw.scm (mingw-w64-tools): Use G-Expressions.

Change-Id: I690d0aeae6c6920d2e3eb43732d6b421a3dfc59b
---
 gnu/packages/mingw.scm | 70 +++++++++++++++++++++---------------------
 1 file changed, 35 insertions(+), 35 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/mingw.scm b/gnu/packages/mingw.scm
index e2fb84ce63..88a2db2141 100644
--- a/gnu/packages/mingw.scm
+++ b/gnu/packages/mingw.scm
@@ -162,45 +162,45 @@  (define-public mingw-w64-tools
         (base32 "047f4m37kxf7g8qj23qplrzfd9cirfkkv8d175sfv2zfd7hbqriz"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:modules ((guix build gnu-build-system)
-                  (guix build utils)
-                  (srfi srfi-1))
+     (list
+       #:modules '((guix build gnu-build-system)
+                   (guix build utils)
+                   (srfi srfi-1))
        #:phases
-       (append
-        (modify-phases %standard-phases
-          (add-after 'unpack 'cd-gendef
-            (lambda _
-              (chdir "mingw-w64-tools/gendef"))))
-        (modify-phases %standard-phases
-          (replace 'unpack
-            (lambda _
-              (chdir "../genidl"))))
-        (modify-phases %standard-phases
-          (replace 'unpack
-            (lambda _
-              (chdir "../genlib"))))
-        (modify-phases %standard-phases
-          (replace 'unpack
-            (lambda _
-              (chdir "../genpeimg"))))
-        (append-map
-         (lambda (target)
+       #~(append
+           (modify-phases %standard-phases
+             (add-after 'unpack 'cd-gendef
+               (lambda _
+                 (chdir "mingw-w64-tools/gendef"))))
+           (modify-phases %standard-phases
+             (replace 'unpack
+               (lambda _
+                 (chdir "../genidl"))))
+           (modify-phases %standard-phases
+             (replace 'unpack
+               (lambda _
+                 (chdir "../genlib"))))
            (modify-phases %standard-phases
              (replace 'unpack
                (lambda _
-                 (chdir "../widl")
-                 (false-if-exception
-                  (delete-file-recursively "../build"))
-                 #t))
-             (replace 'configure
-               (lambda args
-                 (apply (assoc-ref %standard-phases 'configure)
-                        (append args (list #:out-of-source? #t
-                                           #:configure-flags
-                                           `("--target" ,target
-                                             "--program-prefix"
-                                             ,(string-append target "-")))))))))
-         '("i686-w64-mingw32" "x86_64-w64-mingw32")))))
+                 (chdir "../genpeimg"))))
+           (append-map
+            (lambda (target)
+              (modify-phases %standard-phases
+                (replace 'unpack
+                  (lambda _
+                    (chdir "../widl")
+                    (false-if-exception
+                     (delete-file-recursively "../build"))))
+                (replace 'configure
+                  (lambda args
+                    (apply (assoc-ref %standard-phases 'configure)
+                           (append args (list #:out-of-source? #t
+                                              #:configure-flags
+                                              `("--target" ,target
+                                                "--program-prefix"
+                                                ,(string-append target "-")))))))))
+            '("i686-w64-mingw32" "x86_64-w64-mingw32")))))
     (home-page "https://mingw-w64.org")
     (synopsis "Tools of Minimalist GNU for Windows")
     (description "This package provides the tools of Minimalist GNU for