diff mbox series

[bug#63264] gnu: Add r-rcircos.

Message ID 33d7f10371cd040af37e32bf85298f58b9c34942.1683208070.git.navid.afkhami@mdc-berlin.de
State New
Headers show
Series [bug#63264] gnu: Add r-rcircos. | expand

Commit Message

nafkhamdc May 4, 2023, 1:47 p.m. UTC
* gnu/packages/cran.scm (r-rcircos): New variable.
---
 gnu/packages/cran.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)


base-commit: 916c6e5716bd14cb328f7dcce5405ba9100bb908

Comments

Ricardo Wurmus May 4, 2023, 5:23 p.m. UTC | #1
Applied, thank you!
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 5d6acda230..9d62b2dbe8 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5676,6 +5676,28 @@  (define-public r-circlize
 multi-dimensional data.")
     (license license:gpl2+)))
 
+(define-public r-rcircos
+  (package
+    (name "r-rcircos")
+    (version "1.2.2")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "RCircos" version))
+              (sha256
+               (base32
+                "1z0aam60p1b6q7csn50rrwdilm07myr05bw54s9ah8idzyxc7gav"))))
+    (properties `((upstream-name . "RCircos")))
+    (build-system r-build-system)
+    (home-page "https://cran.r-project.org/web/packages/RCircos/")
+    (synopsis "Circos 2D track plot")
+    (description
+     "Simple and flexible way to generate Circos 2D track plot images.
+The types of plots include: heatmap, histogram, lines, scatterplot,
+tiles and plot items for further decorations include connector, link
+(lines and ribbons), and text (gene) label.  All functions require
+only R graphics package that comes with R base installation.")
+    (license license:gpl2+)))
+
 (define-public r-ctrdata
   (package
     (name "r-ctrdata")