diff mbox series

[bug#70692,v3] gnu: audacity: update to 3.5.1.

Message ID 33886d2437435649aea2ab842537515f64c417b2.1714554953.git.atai@atai.org
State New
Headers show
Series [bug#70692,v3] gnu: audacity: update to 3.5.1. | expand

Commit Message

Andy Tai May 1, 2024, 9:16 a.m. UTC
* gnu/packages/audio.scm (audacity): Update to 3.5.1.
  [inputs]: Add opusfile and rapidjson.

* gnu/packages/patches/audacity-ffmpeg-fallback.patch: Delete.

Change-Id: I4245ba1fa21bb54c6b647b001ae9b5cea846c774
---
 gnu/packages/audio.scm                        |  7 ++-
 .../patches/audacity-ffmpeg-fallback.patch    | 61 -------------------
 2 files changed, 4 insertions(+), 64 deletions(-)
 delete mode 100644 gnu/packages/patches/audacity-ffmpeg-fallback.patch


base-commit: 7d7fca19429cf9d38125610f46333eb02fc2d3fd
diff mbox series

Patch

diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 1a88698165..7d4c7e269b 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -924,7 +924,7 @@  (define-public ardour
 (define-public audacity
   (package
     (name "audacity")
-    (version "3.3.3")            ;for ffmpeg 6 support
+    (version "3.5.1")            ;for ffmpeg 6 support
     (source
      (origin
        (method git-fetch)
@@ -933,8 +933,7 @@  (define-public audacity
              (commit (string-append "Audacity-" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "07jbql4jl2198z0rsa1nsf4p045iv4gz6ym75a60yyznvg0h0zwv"))
-       (patches (search-patches "audacity-ffmpeg-fallback.patch"))
+        (base32 "11sjyz6hxsr5dnndkkkiq7arjxvjl1sycl151xq3a3ggakgql3y1"))
        (modules '((guix build utils)))
        (snippet
         ;; Remove bundled libraries.
@@ -969,6 +968,8 @@  (define-public audacity
            ;;("libsbsms" ,libsbsms)         ;bundled version is modified
            libsndfile
            mpg123
+           opusfile
+           rapidjson
            soundtouch
            soxr                         ;replaces libsamplerate
            sqlite
diff --git a/gnu/packages/patches/audacity-ffmpeg-fallback.patch b/gnu/packages/patches/audacity-ffmpeg-fallback.patch
deleted file mode 100644
index d18583c9bd..0000000000
--- a/gnu/packages/patches/audacity-ffmpeg-fallback.patch
+++ /dev/null
@@ -1,61 +0,0 @@ 
-From 3c20057d0cbbbed453a692d4dd4589d865808024 Mon Sep 17 00:00:00 2001
-From: Liliana Marie Prikler <liliana.prikler@gmail.com>
-Date: Sat, 29 Jan 2022 10:44:44 +0100
-Subject: [PATCH] Add pkg-config fallback for locating ffmpeg.
-
-Audacity >=3.1.0 no longer links against ffmpeg, but instead dynamically loads
-it.  This dynamic loading mechanism fails to properly locate libraries outside
-of LD_LIBRARY_PATH.
-
-See <https://issues.guix.gnu.org/53591>.
-
-Bugs-added-by: Marius Bakke <marius@gnu.org>
-
-diff --git a/libraries/lib-ffmpeg-support/CMakeLists.txt b/libraries/lib-ffmpeg-support/CMakeLists.txt
-index b8803a1f5..f86559cca 100644
---- a/libraries/lib-ffmpeg-support/CMakeLists.txt
-+++ b/libraries/lib-ffmpeg-support/CMakeLists.txt
-@@ -1,5 +1,7 @@
- 
- if (${_OPT}use_ffmpeg)
-+   pkg_check_modules(FFMPEG libavcodec libavformat libavutil)
-+
-    set( SOURCES
-       FFmpegTypes.h
- 
-@@ -107,6 +109,12 @@ if (${_OPT}use_ffmpeg)
-       list(APPEND DEFINITIONS PRIVATE _DARWIN_C_SOURCE )
-    endif()
- 
-+   if (FFMPEG_FOUND)
-+      pkg_get_variable(LIBAVCODEC_LIBDIR libavcodec libdir)
-+      list(APPEND DEFINITIONS PRIVATE
-+                  "-DFFMPEG_PC_LIBDIR=\"${LIBAVCODEC_LIBDIR}\"")
-+   endif()
-+
-    audacity_library( lib-ffmpeg-support "${SOURCES}" "${LIBRARIES}"
-       "${DEFINITIONS}" ""
-    )
-diff --git a/libraries/lib-ffmpeg-support/FFmpegFunctions.cpp b/libraries/lib-ffmpeg-support/FFmpegFunctions.cpp
-index 55d6f676b..46640ef83 100644
---- a/libraries/lib-ffmpeg-support/FFmpegFunctions.cpp
-+++ b/libraries/lib-ffmpeg-support/FFmpegFunctions.cpp
-@@ -246,6 +246,18 @@ struct FFmpegFunctions::Private final
-       if (library->IsLoaded())
-          return library;
- 
-+#if defined(FFMPEG_PC_LIBDIR)
-+      {
-+         static const wxString libdir{FFMPEG_PC_LIBDIR};
-+         const wxString fullName = wxFileName(libdir, libraryName).GetFullPath();
-+
-+         auto library = std::make_shared<wxDynamicLibrary>(fullName);
-+
-+         if (library->IsLoaded())
-+            return library;
-+      }
-+#endif
-+
-       return {};
-    }
- };