diff mbox series

[bug#56729,RFC,v3,28/32] gnu: singular: Don't compress info file.

Message ID 333ceb3cc92c2ab272b35a7d29edcfad6a98f2a3.1685391448.git.guix@ikherbers.com
State New
Headers show
Series None | expand

Commit Message

vicvbcun May 29, 2023, 8:38 p.m. UTC
Singular doesn't find the compressed file.

* gnu/packages/algebra.scm (singular)[arguments]<#:phases>: Delete phase
'compress-documentation.
---
 gnu/packages/algebra.scm | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 9ea4cfbf09..df3ec30718 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -670,7 +670,10 @@  (define-public singular
    (arguments
     `(#:configure-flags
       (list (string-append "--with-ntl="
-                           (assoc-ref %build-inputs "ntl")))))
+                           (assoc-ref %build-inputs "ntl")))
+      #:phases (modify-phases %standard-phases
+                 ;; singular doesn't find its compressed info file
+                 (delete 'compress-documentation))))
    (synopsis "Computer algebra system for polynomial computations")
    (description
     "Singular is a computer algebra system for polynomial computations,