[bug#77371,08/12] gnu: Add python-hepunits.

Message ID 333047db64aeee783ec837a96b33acd92c81c67a.1743288280.git.monego@posteo.net
State New
Headers
Series Add packages from the scikit-hep project |

Commit Message

Vinicius Monego March 29, 2025, 11:01 p.m. UTC
  * gnu/packages/python-science.scm (python-hepunits): New variable.

Change-Id: I174495c4fdacd21491e9e7d5abdd7d5dd0e5ffe8
---
 gnu/packages/python-science.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
  

Patch

diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index c1fabfa7bd..876c68912a 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -1124,6 +1124,25 @@  (define-public python-tdda
 of regular expressions from text data and automatic test generation.")
     (license license:expat))) ; MIT License
 
+(define-public python-hepunits
+  (package
+    (name "python-hepunits")
+    (version "2.3.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "hepunits" version))
+       (sha256
+        (base32 "1n1nf2rz2d86qzjmcwykbc16jzsqb45vs8lyksg98b3jd8nwsd4l"))))
+    (build-system pyproject-build-system)
+    (native-inputs (list python-hatch-vcs python-hatchling python-pytest))
+    (home-page "https://github.com/scikit-hep/hepunits")
+    (synopsis "Units and constants in the HEP system of units")
+    (description "@code{hepunits} collects the most commonly used units and
+constants in the HEP System of Units, as derived from the basic units
+originally defined by the CLHEP project.")
+    (license license:bsd-3)))
+
 (define-public python-trimesh
   (package
     (name "python-trimesh")