diff mbox series

[bug#54449] opencv: add flag OPENCV_GENERATE_PKGCONFIG required for openFrameworks

Message ID 32b63bbb7db9533ac1b86a93272a3fafcb489c49.1647617079.git.blake@nonconstructivism.com
State Accepted
Headers show
Series [bug#54449] opencv: add flag OPENCV_GENERATE_PKGCONFIG required for openFrameworks | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Blake Shaw March 18, 2022, 3:24 p.m. UTC
---
 gnu/packages/image-processing.scm | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

Comments

Mathieu Othacehe March 22, 2022, 10:31 a.m. UTC | #1
Hello,

I added a commit message, 

> +
> +opencv

removed that bit, and pushed as
614a7610dab88f5124f2837e70ff878861ef2d8d.

Thanks,

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index 272f400f67..975a5eb792 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -428,7 +428,7 @@  (define-public opencv
              "-DWITH_ITT=OFF"
              "-DWITH_CAROTENE=OFF" ; only visible on arm/aarch64
              "-DENABLE_PRECOMPILED_HEADERS=OFF"
-
+             "-DOPENCV_GENERATE_PKGCONFIG=ON"
              ;; CPU-Features:
              ;; See cmake/OpenCVCompilerOptimizations.cmake
              ;; (CPU_ALL_OPTIMIZATIONS) for a list of all optimizations
@@ -1303,3 +1303,5 @@  (define-public labelme
       "Image and video labeling tool supporting different shapes like
 polygons, rectangles, circles, lines, points and VOC/COCO export.")
     (license license:gpl3+)))
+
+opencv