diff mbox series

[bug#54974] added btop

Message ID 32AB7591-1B34-4AA9-B503-5CAFBCE10D60@4tii.de
State Accepted
Headers show
Series [bug#54974] added btop | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Wil deBeest April 28, 2022, 11:17 p.m. UTC
Hi Maxime,

> Long term, %outputs, %build-inputs, ... are being phased out, so I'd go
> with, so I'd go with
> 
>   (arguments (list #:make-flags #~(string-append "PREFIX=" #$output)))
> 
> here instead.

I haven't been able to integrate your snippet into the package.   Could you
show me how to do so or tell me which part of the handbook would be
relevant?


> can 'bashtop' and 'bpytop' be removed now? (Using
> '(deprecated-package ...) for a smooth transition).

The projects are all by the same developer and bashtop hasn't changed in two years, so the assumption that the rewrites supersede the older implementations doesn't seem farfetched.


> What's an UP and DOWN key?  I just have a regular up and down keys but
> no fancy uppercase UP and DOWN keys ...
> [...]
> It's a list, so you can use the Texinfo markup @itemize, @item and @end
> itemize here.  It's also leaning a bit towards marketing talk with the
> ‘and more ...’ and rather subjective ‘fast and responsive UI’, ...

That was just copy & paste, I had forgotten about cut ;)


Cheers
Wil



|--------------------------|
| [PATCH] added btop 1.2.6 |
|--------------------------|


---
gnu/packages/admin.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)


base-commit: 882cacc1bb5be0df334dd7ce55b385a3a1678728

Comments

M April 29, 2022, 9:37 a.m. UTC | #1
Wil deBeest schreef op vr 29-04-2022 om 01:17 [+0200]:
> Hi Maxime,
> 
> > Long term, %outputs, %build-inputs, ... are being phased out, so I'd go
> > with, so I'd go with
> > 
> >    (arguments (list #:make-flags #~(string-append "PREFIX=" #$output)))
> > 
> > here instead.
> 
> I haven't been able to integrate your snippet into the package.   Could you
> show me how to do so or tell me which part of the handbook would be
> relevant?

For a good example, see the 'stress-ng' package definition 'guix edit
stress-ng'.  #:make-flags is documented in the manual (search for
#:make-flags or go to (guix)Build Systems).  #$output is documented in
‘(guix)G-Expressions’.

Very concretely:

  (package
    [...]
    (arguments (list #:tests? #false ; some comment
                     #:make-flags #~(...)
                     #:phases
                     ;; [Stuff for replacing the install phase and
                     ;; removing the configure phase]
                     #~(modify-phases %standard-phases ...))))

Greetings,
Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index a200050d97..7b2e9660e1 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -752,6 +752,36 @@  (define-public bpytop
@command{bashtop}.")
    (license license:asl2.0)))

+(define-public btop
+  (package
+    (name "btop")
+    (version "1.2.6")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/aristocratos/btop")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "03nd34q1w01visd2bg7mxrcjn0s6lnbm4s0vsfsj2mfv1rvyjl5b"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:make-flags
+       (list (string-append "PREFIX=" %output))
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure))
+        #:tests? #f))
+    (home-page "https://github.com/aristocratos/btop")
+    (synopsis "Resource monitor")
+    (description "Resource monitor that shows usage and stats
+for processor, memory, disks, network and processes.
+
+C++ version and continuation of bashtop and bpytop.")
+    (license license:asl2.0)))
+
(define-public pies
  (package
    (name "pies")