diff mbox series

[bug#35518] gnu: guile-pfds bugfix

Message ID 3279cee19940b90be0bbe34b6619fe89@hyper.dev
State Accepted
Headers show
Series [bug#35518] gnu: guile-pfds bugfix | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Amirouche May 1, 2019, 11:46 a.m. UTC
On 2019-05-01 08:20, Ricardo Wurmus wrote:
> 
> I’d prefer not to add a patch file here but to add a build phase after
> unpack that uses substitute* to patch the file.
> 

new patch

Comments

Ludovic Courtès May 6, 2019, 8:05 a.m. UTC | #1
Hi Amirouche,

amirouche@hyper.dev skribis:

> On 2019-05-01 08:20, Ricardo Wurmus wrote:
>>
>> I’d prefer not to add a patch file here but to add a build phase after
>> unpack that uses substitute* to patch the file.
>>
>
> new patch
>
> From de22b734f37c2701121b990fe1fda5ead67ece31 Mon Sep 17 00:00:00 2001
> From: Amirouche <amirouche+dev@hyper.dev>
> Date: Wed, 1 May 2019 13:41:59 +0200
> Subject: [PATCH] gnu: guile-pfds bugfix
>
> - gnu/packages/guile-xyz.scm(guile-pfds)[version]: upgrade to 0.3-0
> - gnu/packages/guile-xyz.scm(guile-pfds)[commit]: hardcode v0.3
> - gnu/packages/guile-xyz.scm(guile-pfds)[arguments]: New phase 'patch'

[...]

> +                  (add-after 'unpack 'patch
> +                    (lambda _
> +                      (substitute* "hamts.sls"
> +                        (("subtrie-vector vector")
> +                         "subtrie-vector trie"))
> +                        #t))

Like Ricardo wrote: “there should be a note about the upstream status of
this change.”  Someone reading this cannot understand what this change
is about nor what upstream thinks about it.

Could you address this issue?

Bonus points if you change it to follow our conventions for the commit
log and for the Git checkouts.  :-)

  https://www.gnu.org/software/guix/manual/en/html_node/Submitting-Patches.html
  https://www.gnu.org/software/guix/manual/en/html_node/Version-Numbers.html

Thanks in advance,
Ludo’.
Ludovic Courtès May 6, 2019, 8:05 a.m. UTC | #2
Hi Amirouche,

amirouche@hyper.dev skribis:

> On 2019-05-01 08:20, Ricardo Wurmus wrote:
>>
>> I’d prefer not to add a patch file here but to add a build phase after
>> unpack that uses substitute* to patch the file.
>>
>
> new patch
>
> From de22b734f37c2701121b990fe1fda5ead67ece31 Mon Sep 17 00:00:00 2001
> From: Amirouche <amirouche+dev@hyper.dev>
> Date: Wed, 1 May 2019 13:41:59 +0200
> Subject: [PATCH] gnu: guile-pfds bugfix
>
> - gnu/packages/guile-xyz.scm(guile-pfds)[version]: upgrade to 0.3-0
> - gnu/packages/guile-xyz.scm(guile-pfds)[commit]: hardcode v0.3
> - gnu/packages/guile-xyz.scm(guile-pfds)[arguments]: New phase 'patch'

[...]

> +                  (add-after 'unpack 'patch
> +                    (lambda _
> +                      (substitute* "hamts.sls"
> +                        (("subtrie-vector vector")
> +                         "subtrie-vector trie"))
> +                        #t))

Like Ricardo wrote: “there should be a note about the upstream status of
this change.”  Someone reading this cannot understand what this change
is about nor what upstream thinks about it.

Could you address this issue?

Bonus points if you change it to follow our conventions for the commit
log and for the Git checkouts.  :-)

  https://www.gnu.org/software/guix/manual/en/html_node/Submitting-Patches.html
  https://www.gnu.org/software/guix/manual/en/html_node/Version-Numbers.html

Thanks in advance,
Ludo’.
diff mbox series

Patch

From de22b734f37c2701121b990fe1fda5ead67ece31 Mon Sep 17 00:00:00 2001
From: Amirouche <amirouche+dev@hyper.dev>
Date: Wed, 1 May 2019 13:41:59 +0200
Subject: [PATCH] gnu: guile-pfds bugfix

- gnu/packages/guile-xyz.scm(guile-pfds)[version]: upgrade to 0.3-0
- gnu/packages/guile-xyz.scm(guile-pfds)[commit]: hardcode v0.3
- gnu/packages/guile-xyz.scm(guile-pfds)[arguments]: New phase 'patch'
---
 gnu/packages/guile-xyz.scm | 14 ++++++++++----
 1 file changed, 10 insertions(+), 4 deletions(-)

diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 03fd63837e..c2f1e2c2f3 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -8,7 +8,7 @@ 
 ;;; Copyright © 2016 Eraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016, 2017 Alex Kost <alezost@gmail.com>
 ;;; Copyright © 2016, 2017 Adonay "adfeno" Felipe Nogueira <https://libreplanet.org/wiki/User:Adfeno> <adfeno@openmailbox.org>
-;;; Copyright © 2016 Amirouche <amirouche@hypermove.net>
+;;; Copyright © 2016, 2019 Amirouche <amirouche@hypermove.net>
 ;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
 ;;; Copyright © 2017 Andy Wingo <wingo@igalia.com>
 ;;; Copyright © 2017 David Thompson <davet@gnu.org>
@@ -626,13 +626,13 @@  using Guile's foreign function interface.")
 (define-public guile-pfds
   (package
     (name "guile-pfds")
-    (version "0.3")
+    (version "0.3-0")
     (home-page "https://github.com/ijp/pfds")
     (source (origin
               (method git-fetch)
               (uri (git-reference
                     (url home-page)
-                    (commit (string-append "v" version))))
+                    (commit "v0.3")))
               (sha256
                (base32
                 "19y33wg94pf0n98dkfqd1zbw93fgky4sawxsxl6s3vyqwl0yi5vh"))
@@ -641,7 +641,13 @@  using Guile's foreign function interface.")
     (arguments
      '(#:source-directory "src"
        #:phases (modify-phases %standard-phases
-                  (add-after 'unpack 'move-files-around
+                  (add-after 'unpack 'patch
+                    (lambda _
+                      (substitute* "hamts.sls"
+                        (("subtrie-vector vector")
+                         "subtrie-vector trie"))
+                        #t))
+                  (add-after 'patch 'move-files-around
                     (lambda _
                       ;; Move files under a pfds/ directory to reflect the
                       ;; module hierarchy.
-- 
2.19.1