diff mbox series

[bug#73994] gnu: bpftrace: Update to 1.21.2.

Message ID 3223c821d377cf78c51d25858cd5c91373ebebad.1729798992.git.ashish.is@lostca.se
State New
Headers show
Series [bug#73994] gnu: bpftrace: Update to 1.21.2. | expand

Commit Message

Ashish SHUKLA Oct. 24, 2024, 7:43 p.m. UTC
This patch also fixes broken compilation due to improper detection
of bfd features. This is taken from following upstream PR:

  https://github.com/bpftrace/bpftrace/pull/3332

* gnu/packages/linux.scm (bpftrace): Update to 1.21.2.
[arguments]<phases> Rename, and update "patch-paths" phase.

Change-Id: If7180d4da8073914172296f46a3427ccdff22478
---
 gnu/packages/linux.scm | 12 +++++++++---
 1 file changed, 9 insertions(+), 3 deletions(-)


base-commit: 2394a7f5fbf60dd6adc0a870366adb57166b6d8b

Comments

Z572 Oct. 28, 2024, 4:34 a.m. UTC | #1
Ashish SHUKLA via Guix-patches via <guix-patches@gnu.org> writes:

> This patch also fixes broken compilation due to improper detection
> of bfd features. This is taken from following upstream PR:
>
>   https://github.com/bpftrace/bpftrace/pull/3332
>
> * gnu/packages/linux.scm (bpftrace): Update to 1.21.2.
> [arguments]<phases> Rename, and update "patch-paths" phase.
>
> Change-Id: If7180d4da8073914172296f46a3427ccdff22478
> ---
>  gnu/packages/linux.scm | 12 +++++++++---
>  1 file changed, 9 insertions(+), 3 deletions(-)
>
> diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
> index e0785cccf7..6578dd2e97 100644
> --- a/gnu/packages/linux.scm
> +++ b/gnu/packages/linux.scm
> @@ -10343,7 +10343,7 @@ (define-public bpftool
>  (define-public bpftrace
>    (package
>      (name "bpftrace")
> -    (version "0.21.0")
> +    (version "0.21.2")
>      (source
>       (origin
>         (method git-fetch)
> @@ -10352,7 +10352,7 @@ (define-public bpftrace
>               (commit (string-append "v" version))))
>         (file-name (git-file-name name version))
>         (sha256
> -        (base32 "06yg3w80kdq0i003w2gvn0czbh8z9d3rfgmglp37dkir7g3dc6iz"))))
> +        (base32 "0icbhf1wk523a7lcmwqa67zc6hl6h02p5mfg26cizva447kbwsgz"))))
>      (build-system cmake-build-system)
>      (arguments (list #:configure-flags #~(list "-DBUILD_TESTING=ON")
>                       ;; Only run the unit tests suite, as the other ones
> @@ -10360,8 +10360,14 @@ (define-public bpftrace
>                       ;; 'root'.
>                       #:test-target "bpftrace_test"
>                       #:phases #~(modify-phases %standard-phases
> -                                  (add-after 'unpack 'patch-paths
> +                                  (add-after 'unpack 'patch-paths-and-bfd-defs
>                                      (lambda _
> +                                      (substitute* '("cmake/FindLibBfd.cmake"
> +                                                     "src/CMakeLists.txt")
> +                                        (("LIBSFRAME_FOUND")
> +                                         "LIBSFRAME_LIBRARIES")
> +                                        (("LIBZSTD_FOUND")
> +                                         "LIBZSTD_LIBRARIES"))
>                                        (with-directory-excursion "tests"
>                                          (substitute* (find-files ".")
>                                            (("/bin/sh")
>
> base-commit: 2394a7f5fbf60dd6adc0a870366adb57166b6d8b

push, and move comments to code.
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index e0785cccf7..6578dd2e97 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -10343,7 +10343,7 @@  (define-public bpftool
 (define-public bpftrace
   (package
     (name "bpftrace")
-    (version "0.21.0")
+    (version "0.21.2")
     (source
      (origin
        (method git-fetch)
@@ -10352,7 +10352,7 @@  (define-public bpftrace
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "06yg3w80kdq0i003w2gvn0czbh8z9d3rfgmglp37dkir7g3dc6iz"))))
+        (base32 "0icbhf1wk523a7lcmwqa67zc6hl6h02p5mfg26cizva447kbwsgz"))))
     (build-system cmake-build-system)
     (arguments (list #:configure-flags #~(list "-DBUILD_TESTING=ON")
                      ;; Only run the unit tests suite, as the other ones
@@ -10360,8 +10360,14 @@  (define-public bpftrace
                      ;; 'root'.
                      #:test-target "bpftrace_test"
                      #:phases #~(modify-phases %standard-phases
-                                  (add-after 'unpack 'patch-paths
+                                  (add-after 'unpack 'patch-paths-and-bfd-defs
                                     (lambda _
+                                      (substitute* '("cmake/FindLibBfd.cmake"
+                                                     "src/CMakeLists.txt")
+                                        (("LIBSFRAME_FOUND")
+                                         "LIBSFRAME_LIBRARIES")
+                                        (("LIBZSTD_FOUND")
+                                         "LIBZSTD_LIBRARIES"))
                                       (with-directory-excursion "tests"
                                         (substitute* (find-files ".")
                                           (("/bin/sh")