[bug#78252,5/5] gnu: Add python-beangulp.
Commit Message
* gnu/packages/finance.scm (python-beangulp): New variable.
Change-Id: Id3fa32decb1ec3fe6d9f697a8647f1b826f022be
---
gnu/packages/finance.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)
@@ -2109,6 +2109,33 @@ (define-public beanquery
(description "Customizable lightweight SQL query tool.")
(license license:gpl2)))
+(define-public python-beangulp
+ (package
+ (name "python-beangulp")
+ (version "0.2.0")
+ (source
+ (origin
+ (method git-fetch) ;no test data files in PyPI archive
+ (uri (git-reference
+ (url "https://github.com/beancount/beangulp")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0zlanw88dq7czgsdvqwz2fgxamyrfnx15ymv4d7fnjrj04glpg47"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list beancount-3
+ python-beautifulsoup4
+ python-chardet
+ python-petl
+ python-click
+ python-lxml
+ python-magic))
+ (native-inputs (list python-setuptools python-wheel python-pytest))
+ (home-page "https://github.com/beancount/beangulp")
+ (synopsis "Importers Framework for Beancount")
+ (description "Importers Framework for Beancount.")
+ (license license:gpl2)))
+
(define-public fava
(package
(name "fava")