diff mbox series

[bug#71076,32/81] gnu: Add rust-android-log-sys-0.3.

Message ID 31c7a425aed38144c1630e6e1f9108d586c9357e.1716193123.git.herman@rimm.ee
State New
Headers show
Series Add matrix-conduit and ruma-0.10. | expand

Commit Message

Herman Rimm May 20, 2024, 8:58 a.m. UTC
* gnu/packages/crates-io.scm (rust-android-log-sys-0.3): Add variable.
(rust-android-log-sys-0.2): Inherit from rust-android-log-sys-0.3.

Change-Id: I432f1d580746a693851b8b2d360b4d8ece2304af
---
 gnu/packages/crates-io.scm | 24 +++++++++++++++++++-----
 1 file changed, 19 insertions(+), 5 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index f170b04efb..e7902fec50 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -1536,24 +1536,38 @@  (define-public rust-android-glue-0.2
     (description "This package provides the glue for the Android JNI.")
     (license license:expat)))
 
-(define-public rust-android-log-sys-0.2
+(define-public rust-android-log-sys-0.3
   (package
     (name "rust-android-log-sys")
-    (version "0.2.0")
+    (version "0.3.1")
     (source
      (origin
        (method url-fetch)
        (uri (crate-uri "android_log-sys" version))
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
-        (base32 "0bhhs1cgzp9vzjvkn2q31ppc7w4am5s273hkvl5iac5475kmp5l5"))))
-    (arguments `(#:skip-build? #true))  ;XXX: Android only
+        (base32 "0dwrvwkx2xxqys6nrhfavbbqfx2rs61nq8akrlnqkfbapxb81k2y"))))
     (build-system cargo-build-system)
-    (home-page "https://github.com/nercury/android_log-sys-rs")
+    (arguments `(#:skip-build? #true))  ;XXX: Android only
+    (home-page "https://github.com/rust-mobile/android_log-sys-rs")
     (synopsis "FFI bindings to Android log Library")
     (description "This package provides FFI bindings to Android log Library.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-android-log-sys-0.2
+  (package
+    (inherit rust-android-log-sys-0.3)
+    (name "rust-android-log-sys")
+    (version "0.2.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "android_log-sys" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+          "0bhhs1cgzp9vzjvkn2q31ppc7w4am5s273hkvl5iac5475kmp5l5"))))))
+
 (define-public rust-android-log-sys-0.1
   (package
     (inherit rust-android-log-sys-0.2)