diff mbox series

[bug#63886] gnu: Add swayfx.

Message ID 31c748aa13ae690c6fdd5f5910739a687e177a52.1685855062.git.vesselwave@disroot.org
State New
Headers show
Series [bug#63886] gnu: Add swayfx. | expand

Commit Message

Vessel Wave June 4, 2023, 4:56 a.m. UTC
Blur has recently been added to Swayfx
---
 gnu/packages/wm.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)


base-commit: b3492964c2573993b65c20f6e7d16c29cfd6f4f5

Comments

Jonathan Brielmaier June 5, 2023, 7:58 a.m. UTC | #1
Closing. Duplicate of https://issues.guix.gnu.org/63887
Jonathan Brielmaier June 5, 2023, 7:59 a.m. UTC | #2
Closing. Duplicate of https://issues.guix.gnu.org/63887
diff mbox series

Patch

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 7f5e10b60d..2927828c79 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -62,6 +62,7 @@ 
 ;;; Copyright © 2022 zamfofex <zamfofex@twdb.moe>
 ;;; Copyright © 2023 Gabriel Wicki <gabriel@erlikon.ch>
 ;;; Copyright © 2023 Jonathan Brielamier <jonathan.brielmaier@web.de>
+;;; Copyright © 2023 Vessel Wave <vesselwave@disroot.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1669,6 +1670,29 @@  (define-public sway
     (description "Sway is a i3-compatible Wayland compositor.")
     (license license:expat)))

+(define-public swayfx
+  (package
+    (inherit sway)
+    (name "swayfx")
+    (version "0.3.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/WillPower3309/swayfx")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1550n9xnqbl1am4cwlnj8ip5cs7kgdzx96ga2hkcw29cpyian7rv"))))
+    (build-system meson-build-system)
+    (home-page "https://github.com/WillPower3309/swayfx")
+    (synopsis "Sway Fork with extra options and effects")
+    (description
+     "Fork of Sway, a Wayland compositor compatible with i3.  SwayFX
+adds extra options and effects to the original Sway, such as blur, rounded
+corners, shadows, inactive window dimming, etc.")
+    (license license:expat)))
+
 (define-public swayidle
   (package
     (name "swayidle")