diff mbox series

[bug#71125] gnu: buildah: Update to 1.35.4 [security fixes].

Message ID 3199a6f4c03372b649f40145a4da52837f9a1f70.1716403923.git.~@wolfsden.cz
State New
Headers show
Series [bug#71125] gnu: buildah: Update to 1.35.4 [security fixes]. | expand

Commit Message

Tomas Volf May 22, 2024, 6:52 p.m. UTC
This fixes CVE-2024-3727 and CVE-2024-28180.

* gnu/packages/containers.scm (buildah): Update to 1.35.4.

Change-Id: I5ee2b4591b39ee85d7236aedda7a2508df8e0e48
---
 gnu/packages/containers.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Maxim Cournoyer May 30, 2024, 1:28 p.m. UTC | #1
Hi,

Tomas Volf <~@wolfsden.cz> writes:

> This fixes CVE-2024-3727 and CVE-2024-28180.
>
> * gnu/packages/containers.scm (buildah): Update to 1.35.4.

I see another patch of yours has landed meanwhile, updating it to
1.36.0.  I trust this is resolved.
Tomas Volf May 30, 2024, 2:08 p.m. UTC | #2
On 2024-05-30 09:28:03 -0400, Maxim Cournoyer wrote:
> Hi,
>
> Tomas Volf <~@wolfsden.cz> writes:
>
> > This fixes CVE-2024-3727 and CVE-2024-28180.
> >
> > * gnu/packages/containers.scm (buildah): Update to 1.35.4.
>
> I see another patch of yours has landed meanwhile, updating it to
> 1.36.0.  I trust this is resolved.

Yes, I believe so.  I should have paid more attention and close this (obsolete)
patch.  Sorry about that.

Tomas

--
There are only two hard things in Computer Science:
cache invalidation, naming things and off-by-one errors.
Maxim Cournoyer May 30, 2024, 8:35 p.m. UTC | #3
Hi Tomas,

Tomas Volf <~@wolfsden.cz> writes:

> On 2024-05-30 09:28:03 -0400, Maxim Cournoyer wrote:
>> Hi,
>>
>> Tomas Volf <~@wolfsden.cz> writes:
>>
>> > This fixes CVE-2024-3727 and CVE-2024-28180.
>> >
>> > * gnu/packages/containers.scm (buildah): Update to 1.35.4.
>>
>> I see another patch of yours has landed meanwhile, updating it to
>> 1.36.0.  I trust this is resolved.
>
> Yes, I believe so.  I should have paid more attention and close this (obsolete)
> patch.  Sorry about that.

No worries!  Thanks for the heads-up.
diff mbox series

Patch

diff --git a/gnu/packages/containers.scm b/gnu/packages/containers.scm
index 917d152609..f733bb6b6c 100644
--- a/gnu/packages/containers.scm
+++ b/gnu/packages/containers.scm
@@ -609,7 +609,7 @@  (define-public podman-compose
 (define-public buildah
   (package
     (name "buildah")
-    (version "1.35.3")
+    (version "1.35.4")
     (source
      (origin
        (method git-fetch)
@@ -617,7 +617,7 @@  (define-public buildah
              (url "https://github.com/containers/buildah")
              (commit (string-append "v" version))))
        (sha256
-        (base32 "07hr2cfp4kblnmva02ap97id5nzhbqigdfvx7c8nyrkfzw0340n0"))
+        (base32 "1p21lh8ds688nv0valzgl6s20bwzsyvr1sa15ra2mprj79azvl4r"))
        (file-name (git-file-name name version))))
     (build-system gnu-build-system)
     (arguments