[bug#76796] gnu: fish: Add support for guix home profile.
Commit Message
* gnu/packages/shells.scm (fish)[arguments]<#:phases>
{patch-fish-extra-paths}: Add `~/.guix-home/profile' to `__guix_profile_paths'.
Change-Id: If896cfc4f948d86c52073235a6f4a2c1d085e7a6
---
Currently, the completions, configurations and functions installed in
~/.guix-home/profile/etc/fish/{completions,conf.d,functions} are ignored,
as these directories aren't listed under __fish_vendor_completionsdirs,
__fish_vendor_confdirs and __fish_vendor_functionsdirs. This patch
addresses, and fixes, this issue.
gnu/packages/shells.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
base-commit: 310adf4ce70cbb864859274fcc7842bd519bbddc
Comments
Luis Guilherme Coelho <lgcoelho@disroot.org> skribis:
> * gnu/packages/shells.scm (fish)[arguments]<#:phases>
> {patch-fish-extra-paths}: Add `~/.guix-home/profile' to `__guix_profile_paths'.
>
> Change-Id: If896cfc4f948d86c52073235a6f4a2c1d085e7a6
Applied, thanks!
@@ -223,10 +223,10 @@ (define-public fish
(string-append
"\n\n"
"# Patched by Guix.\n"
- "# Enable completions, functions and configurations in user's"
- " and system's guix profiles by adding them to __extra_*"
+ "# Enable completions, functions and configurations in user's,"
+ " home's and system's guix profiles by adding them to __extra_*"
" variables.\n"
- "set -l __guix_profile_paths ~/.guix-profile"
+ "set -l __guix_profile_paths ~/.guix-profile ~/.guix-home/profile"
" /run/current-system/profile\n"
"set __extra_completionsdir"
" $__guix_profile_paths\"/etc/fish/completions\""