diff mbox series

[bug#63111] gnu: fwupd: Update to 1.8.14.

Message ID 313af389e3fd97e465401716e4babef9d7a3bd43.1682598802.git.dev@jpoiret.xyz
State New
Headers show
Series [bug#63111] gnu: fwupd: Update to 1.8.14. | expand

Commit Message

Josselin Poiret April 27, 2023, 12:33 p.m. UTC
From: Josselin Poiret <dev@jpoiret.xyz>

* gnu/packages/firmware.scm (fwupd): Update to 1.8.14.  Also, change two
files' timestamp because they are zipped up by Python.
---
 gnu/packages/firmware.scm | 13 +++++++++++--
 1 file changed, 11 insertions(+), 2 deletions(-)


base-commit: fa685c87eaa9888a4278f39bb2b815673589dced

Comments

Ludovic Courtès April 28, 2023, 7:10 p.m. UTC | #1
Josselin Poiret <dev@jpoiret.xyz> skribis:

> From: Josselin Poiret <dev@jpoiret.xyz>
>
> * gnu/packages/firmware.scm (fwupd): Update to 1.8.14.  Also, change two
> files' timestamp because they are zipped up by Python.

Applied, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
index 0b7fff035a..b6b053b6b4 100644
--- a/gnu/packages/firmware.scm
+++ b/gnu/packages/firmware.scm
@@ -199,7 +199,7 @@  (define-public b43-tools
 (define-public fwupd
   (package
     (name "fwupd")
-    (version "1.8.3")
+    (version "1.8.14")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -208,7 +208,7 @@  (define-public fwupd
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "02jf052qj1nl47ppqrgz3s9qapq4pajgkf6lbj5rxr5sshlrw44n"))))
+                "179yc0nbbyrdya5q16ncf7lkslrhr3i90rgb9vdmv751ikilkby6"))))
     (build-system meson-build-system)
     (arguments
      (list
@@ -236,6 +236,15 @@  (define-public fwupd
               (substitute* "src/fu-self-test.c"
                 (("/bin/sh")
                  (which "sh")))))
+          ;; These two files are zipped by Python, so need a newer timestamp.
+          (add-after 'unpack 'newer-timestamps-for-python-zip
+            (lambda _
+              (let ((circa-1980 (* 10 366 24 60 60)))
+                (for-each (lambda (file)
+                            (make-file-writable file)
+                            (utime file circa-1980 circa-1980))
+                          '("./libfwupdplugin/tests/colorhug/firmware.bin"
+                            "./libfwupdplugin/tests/colorhug/firmware.bin.asc")))))
           (add-before 'build 'setup-home
             (lambda _
               (setenv "HOME" "/tmp")))