[bug#78514] gnu: Add xjump-sdl.
Commit Message
* gnu/packages/games.scm (xjump-sdl): New variable.
Change-Id: I4f4ac85849d50726c1f18bcf1d51e3b6725ba025
---
gnu/packages/games.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)
base-commit: b51bb28993c9d52d65df329ff1de452ba84d2497
@@ -11292,6 +11292,39 @@ (define-public qcheckers
of the classic boardgame checkers (also known as draughts).")
(license license:gpl2+)))
+(define-public xjump-sdl
+ (package
+ (name "xjump-sdl")
+ (version "3.0.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hugomg/xjump-sdl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1macl4aq0zc93kbranzclqxh2jc40asn3bc8cpyywafzbxyha99y"))))
+ (build-system gnu-build-system)
+ (inputs (list sdl2))
+ (arguments
+ (list
+ #:tests? #f ;No tests.
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (invoke "./configure"
+ (string-append "--prefix="
+ (assoc-ref outputs "out"))
+ (string-append "CC="
+ #$(cc-for-target))))))))
+ (home-page "https://github.com/hugomg/xjump-sdl")
+ (synopsis "Falling tower game")
+ (description
+ "This is a reimplementation of the classic Xjump game, using SDL instead of Xlib.")
+ (license license:gpl3)))
+
(define-public xmoto
(package
(name "xmoto")