diff mbox series

[bug#64348] gnu: Add durden.

Message ID 3136090a794cd91a2500d3979236bfc3701f17d9.1688034098.git.a.r.draidi@redscript.org
State New
Headers show
Series [bug#64348] gnu: Add durden. | expand

Commit Message

Ahmad Draidi June 29, 2023, 10:21 a.m. UTC
* gnu/packages/arcan.scm (durden): New variable.
---
 gnu/packages/arcan.scm | 37 +++++++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)


base-commit: ac86174e22fcd762893bd4515786b1376af9397b
diff mbox series

Patch

diff --git a/gnu/packages/arcan.scm b/gnu/packages/arcan.scm
index 7483777ff0..cf85fc95ef 100644
--- a/gnu/packages/arcan.scm
+++ b/gnu/packages/arcan.scm
@@ -1,6 +1,7 @@ 
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2019 L  p R n  d n <guix@lprndn.info>
 ;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2023 Ahmad Draidi <a.r.draidi@redscript.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -19,7 +20,9 @@ 
 
 (define-module (gnu packages arcan)
   #:use-module (guix build-system cmake)
+  #:use-module (guix build-system copy)
   #:use-module (guix build-system gnu)
+  #:use-module (guix gexp)
   #:use-module (guix git-download)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
@@ -272,3 +275,37 @@  (define-public arcan-wayland
 with an Arcan connection point.  It allows Wayland compatible clients
 to connect and render using Arcan.")
     (license license:bsd-3)))
+
+(define-public durden
+  (package
+    (name "durden")
+    (version "0.6.1")
+    (source (origin
+              (method git-fetch)
+              (file-name (git-file-name name version))
+              (uri (git-reference
+                    (url "https://github.com/letoram/durden")
+                    (commit version)))
+              (sha256
+               (base32
+                "03ry8ypsvpjydb9s4c28y3iffz9375pfgwq9q9y68hmj4d89bjvz"))))
+    (build-system copy-build-system)
+    (arguments
+     (list #:install-plan #~'(("durden/" "share/arcan/appl/durden/")
+                              ("distr/durden" "bin/durden"))
+           #:phases #~(modify-phases %standard-phases
+                        (add-after 'unpack 'patch-paths
+                          (lambda* (#:key outputs #:allow-other-keys)
+                            (substitute* "distr/durden"
+                              (("/usr/share/\\$applname")
+                               (string-append (assoc-ref outputs "out")
+                                              "/share/arcan/appl"))))))))
+    (home-page "https://durden.arcan-fe.com/")
+    (synopsis "Desktop Environment for Arcan")
+    (description
+     "Durden is a desktop environment for the Arcan Display Server.
+It serves both as a reference showcase on how to take advantage of some of the
+features in Arcan, and as an entry to the advanced-user side of the desktop
+environment spectrum.")
+    (license (list license:bsd-3 license:expat license:cc-by3.0
+                   license:cc-by4.0 license:asl2.0))))