diff mbox series

[bug#67880] teams: Add ‘core-packages’ team.

Message ID 31136a6326c09473d75801f66d4055dba68a0faf.1702922342.git.ludo@gnu.org
State New
Headers show
Series [bug#67880] teams: Add ‘core-packages’ team. | expand

Commit Message

Ludovic Courtès Dec. 18, 2023, 6:01 p.m. UTC
* etc/teams.scm (bootstrap): Add “gnu/packages/commencement.scm”.
(core-packages): New team.
(Ludovic Courtès): Add to ‘core-packages’ team.

Change-Id: I25f22d436a4dc9bf4c8f577f94cc178cbaa80768
---
 etc/teams.scm | 20 ++++++++++++++++++--
 1 file changed, 18 insertions(+), 2 deletions(-)

Hello Guix!

This is something we discussed last week on IRC: adding a team for
“core” packages.  By that I mean: the GNU tool chain, Guile, all
the things in (gnu packages base), and probably the closure of all
this.

These are the packages we would update on ‘core-updates’, and ideally
we wouldn’t touch any other package on that branch.  (So Python would
be handled on the ‘python-team’ branch, for instance.)

How does that sound?

I know of a handful of people who’d deserve to be members.  :-)

Thanks,
Ludo’.


base-commit: b681e339fa37f2a26763458ee56b31af1d6a7ec5

Comments

Mathieu Othacehe Dec. 25, 2023, 4:43 p.m. UTC | #1
Hey Ludo,

> +(define-team core-packages
> +  (team 'core-packages
> +        #:name "Core packages"
> +        #:description "Core packages: the GNU tool chain, Guile, Coreutils, etc."
> +        #:scope (list "gnu/packages/base.scm"
> +                      "gnu/packages/bootstrap.scm"
> +                      "gnu/packages/commencement.scm"
> +                      "gnu/packages/cross-base.scm"
> +                      "gnu/packages/gcc.scm"
> +                      "gnu/packages/guile.scm"
> +                      "gnu/packages/make-bootstrap.scm"
> +                      "guix/build/gnu-build-system.scm"
> +                      "guix/build/utils.scm"
> +                      "guix/build-system/gnu.scm")))

Seems nice. This has probably already been discussed, but should
core-updates be renamed core-packages here to be more inline with the
teams workflow?

Thanks,

Mathieu
Ludovic Courtès Jan. 5, 2024, 11:04 a.m. UTC | #2
Hi!

Mathieu Othacehe <othacehe@gnu.org> skribis:

>> +(define-team core-packages
>> +  (team 'core-packages
>> +        #:name "Core packages"
>> +        #:description "Core packages: the GNU tool chain, Guile, Coreutils, etc."
>> +        #:scope (list "gnu/packages/base.scm"
>> +                      "gnu/packages/bootstrap.scm"
>> +                      "gnu/packages/commencement.scm"
>> +                      "gnu/packages/cross-base.scm"
>> +                      "gnu/packages/gcc.scm"
>> +                      "gnu/packages/guile.scm"
>> +                      "gnu/packages/make-bootstrap.scm"
>> +                      "guix/build/gnu-build-system.scm"
>> +                      "guix/build/utils.scm"
>> +                      "guix/build-system/gnu.scm")))
>
> Seems nice.

Cool, I’m applying the patch.

> This has probably already been discussed, but should core-updates be
> renamed core-packages here to be more inline with the teams workflow?

IMO yes, that’s the logical next step.  (Maybe we can wait until the
next cycle though, dunno.)

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/etc/teams.scm b/etc/teams.scm
index 76633c2184..9cf827af29 100755
--- a/etc/teams.scm
+++ b/etc/teams.scm
@@ -310,7 +310,8 @@  (define-team go
 (define-team bootstrap
   (team 'bootstrap
         #:name "Bootstrap"
-        #:scope (list "gnu/packages/mes.scm")))
+        #:scope (list "gnu/packages/commencement.scm"
+                      "gnu/packages/mes.scm")))
 
 (define-team embedded
   (team 'embedded
@@ -424,6 +425,21 @@  (define-team core
               (make-regexp* "^guix/scripts/")
               (make-regexp* "^guix/store/"))))
 
+(define-team core-packages
+  (team 'core-packages
+        #:name "Core packages"
+        #:description "Core packages: the GNU tool chain, Guile, Coreutils, etc."
+        #:scope (list "gnu/packages/base.scm"
+                      "gnu/packages/bootstrap.scm"
+                      "gnu/packages/commencement.scm"
+                      "gnu/packages/cross-base.scm"
+                      "gnu/packages/gcc.scm"
+                      "gnu/packages/guile.scm"
+                      "gnu/packages/make-bootstrap.scm"
+                      "guix/build/gnu-build-system.scm"
+                      "guix/build/utils.scm"
+                      "guix/build-system/gnu.scm")))
+
 (define-team games
   (team 'games
         #:name "Games and Toys"
@@ -554,7 +570,7 @@  (define-member (person "Jonathan Brielmaier"
 
 (define-member (person "Ludovic Courtès"
                        "ludo@gnu.org")
-  core home bootstrap installer mentors)
+  core home bootstrap core-packages installer mentors)
 
 (define-member (person "Andreas Enge"
                        "andreas@enge.fr")