diff mbox series

[bug#74342,1/1] gnu: add ruby-text-table

Message ID 31005192-0db9-4e8c-9380-7f972337f59f@mailbox.org
State New
Headers show
Series [bug#74342,1/1] gnu: add ruby-text-table | expand

Commit Message

Quanrong Nov. 13, 2024, 12:12 p.m. UTC
* gnu/packages/ruby.scm (ruby-text-table): New variable.

Change-Id: If2a1990997333085f0ed5cc2895e47984a376722
---
  gnu/packages/ruby.scm | 22 +++++++++++++++++++++-
  1 file changed, 21 insertions(+), 1 deletion(-)

  (define-public jekyll
    (package
      (name "jekyll")

base-commit: 1f057603ef59c7b9c32f610a897321fd75dc4dad
prerequisite-patch-id: 1b22355642355a77f0f59a2489da2e31e16c65da
prerequisite-patch-id: a508f4f08de1cfda59ad18891b5f066ed028dac8
diff mbox series

Patch

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 13092bedf2..50d890b731 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -26,7 +26,7 @@ 
  ;;; Copyright © 2020 Holgr Peters <holger.peters@posteo.de>
  ;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
  ;;; Copyright © 2021 EuAndreh <eu@euandre.org>
-;;; Copyright © 2020 Tomás Ortín Fernández <tomasortin@mailbox.org>
+;;; Copyright © 2020, 2024 Tomás Ortín Fernández <quanrong@mailbox.org>
  ;;; Copyright © 2021 Giovanni Biscuolo <g@xelera.eu>
  ;;; Copyright © 2022 Philip McGrath <philip@philipmcgrath.com>
  ;;; Copyright © 2022-2024 Remco van 't Veer <remco@remworks.net>
@@ -14872,6 +14872,26 @@  (define-public ruby-terminal-table
  Unicode formatted tables.")
      (license license:expat)))

+(define-public ruby-text-table
+  (package
+    (name "ruby-text-table")
+    (version "1.2.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (rubygems-uri "text-table" version))
+       (sha256
+        (base32 "06yhlnb49fn0fhkmi6lrziyv2hd42gcm2zi3sggm2qab48qxn94j"))))
+    (build-system ruby-build-system)
+    (synopsis
+     "Allows you to easily create and format plain text tables, useful 
when working with the terminal or when you want to quickly print 
formatted tables to a dot-matrix printer.")
+    (description
+     "Allows you to easily create and format plain text tables, useful 
when working
+with the terminal or when you want to quickly print formatted tables to a
+dot-matrix printer.")
+    (home-page "https://github.com/aptinio/text-table")
+    (license license:expat)))
+