diff mbox series

[bug#73201,3/3] gnu: folly: Update to 2024.09.09.00.

Message ID 30dc6d9ec3989458be21b829932d7f5f263196ac.1726154167.git.code@greghogan.com
State New
Headers show
Series Update folly. | expand

Commit Message

Greg Hogan Sept. 12, 2024, 4:04 p.m. UTC
* gnu/packages/cpp.scm (folly): Update to 2024.09.09.00.
[inputs]: Add fast-float.

Change-Id: Icbe6ec261561729178df0920a53ece7d4eded15d
---
 gnu/packages/cpp.scm | 14 ++++++++------
 1 file changed, 8 insertions(+), 6 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 3d0e1da7a1..558228db2a 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -1645,7 +1645,7 @@  (define-public cxxopts
 (define-public folly
   (package
     (name "folly")
-    (version "2023.11.06.00")
+    (version "2024.09.09.00")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -1654,18 +1654,20 @@  (define-public folly
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0z0jhkma2qacc2kc27qsiwqwqkv07i9mwpc4vwcbawyzdajq6hd0"))))
+                "17fdigkaxivbrww5yhz9fh25d8pirqjp126zbv4kg4qsprywfww5"))))
     (build-system cmake-build-system)
     (arguments
-     '(;; Tests must be explicitly enabled
-       ;;#:configure-flags '("-DBUILD_TESTS=ON")))
-       ;; Leave tests disabled; see https://github.com/facebook/folly/issues/1456
-       #:tests? #f))
+     (list
+      ;; Tests must be explicitly enabled
+      ;;#:configure-flags #~(list "-DBUILD_TESTS=ON")
+      ;; Leave tests disabled; see https://github.com/facebook/folly/issues/2246
+      #:tests? #f))
     (propagated-inputs
      (list boost gflags glog liburing))
     (inputs
      (list bzip2
            double-conversion
+           fast-float
            fmt
            libaio
            libevent