diff mbox series

[bug#55994,2/3] gnu: Add trytond-gis.

Message ID 30c3c3d661129ccc9a7603e1ac283767f65fe99d.1655293324.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series [bug#55994,1/3] gnu: Add python-geomet. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel June 15, 2022, 11:44 a.m. UTC
* gnu/packages/tryton.scm (trytond-gis): New variable.
---
 gnu/packages/tryton.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 7cbcc8e518..c105d4fe2d 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -1747,6 +1747,26 @@  from the UNECE.  Supported formats are:
 @end itemize")
     (license license:gpl3+)))
 
+(define-public trytond-gis
+  (package
+    (name "trytond-gis")
+    (version "6.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_gis" version))
+       (sha256
+        (base32 "1z6rvwyzisd62bmzhh1g56as7xyvchdsgj52w9q5x908k2jr4pl4"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "trytond_gis"))
+    (native-inputs (%standard-trytond-native-inputs))
+    (propagated-inputs (list python-geomet  trytond))
+    (home-page "https://docs.tryton.org/projects/backend-gis")
+    (synopsis "Geographic Information System support from Tryton")
+    (description "The @emph{Trytond GIS} Tryton module adds GIS (Geographic
+information system) support to Tryton.")
+    (license license:gpl3+)))
+
 (define-public trytond-incoterm
   (package
     (name "trytond-incoterm")