diff mbox series

[bug#42958] Big changes from wip-desktop.

Message ID 30c376fe-1f99-1eb8-9fcb-6502b496965f@raghavgururajan.name
State Accepted
Headers show
Series [bug#42958] Big changes from wip-desktop. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Raghav Gururajan March 26, 2021, 8:38 p.m. UTC
@(rekado|lle-bout|danny)

> So I have attached all the patches for this batch. These are 
> non-signed-off, just for the record. :)

Had to make a change to 0068. Attached the modified patch.

Regards,
RG.

Comments

Léo Le Bouter March 26, 2021, 9:22 p.m. UTC | #1
On Fri, 2021-03-26 at 16:38 -0400, Raghav Gururajan wrote:
> @(rekado|lle-bout|danny)
> 
> > So I have attached all the patches for this batch. These are 
> > non-signed-off, just for the record. :)
> 
> Had to make a change to 0068. Attached the modified patch.
> 
> Regards,
> RG.

Reviewed, back and forth many comments over IRC with Raghav, pushed as
76b689f339c7ef6f10917e18c630189bb2449110.

Everything builds with:

$ ./pre-inst-env guix build -k -v1 glib libsigc++ glibmm gobject-
introspection cairo cairomm pango pangomm gdk-pixbuf gdk-pixbuf+svg
vala libgsf atk atkmm gtk-doc glibmm@2.64 gtkmm@2 cairomm@1.13 wayland
yelp-xsl json-glib at-spi2-atk at-spi2-core atkmm@2.28 pangomm@2.42 
libsigc++@2 vala gtkmm@2 wayland-protocols

The commit history is not perfect, especially the "cosmetic changes"
that also ungraft things, but we also want to move on and do this
actual GNOME 40 upgrade and it is not worth it obsessing over at the
end mostly irrelevant commit history details.

Any dependents that breaks due to these patches we will fix on core-
updates from now on.

Thanks a lot everyone! Let's upgrade GNOME to 40!!
diff mbox series

Patch

From fa06e0c98bf09b75fda1b738d083c3334712a601 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <rg@raghavgururajan.name>
Date: Fri, 26 Mar 2021 10:27:59 -0400
Subject: [PATCH 68/83] gnu: json-glib: Enable documentation and man-pages.

* gnu/packages/gnome.scm (json-glib) [outputs]: New output "doc".
[arguments]<#:configure-flags>[-Ddocs]: New flag.
[-Dman]: New flag.
<#:phases>['patch-docbook]: New phase.
['move-doc]: New phase.
[native-inputs]: Add docbook-xml, docbook-xsl, gtk-doc and libxslt.
---
 gnu/packages/gnome.scm | 38 +++++++++++++++++++++++++++++++++++---
 1 file changed, 35 insertions(+), 3 deletions(-)

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 22fd435feb..e56adee111 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4562,13 +4562,45 @@  configuration storage systems.")
                (base32
                 "092g2dyy1hhl0ix9kp33wcab0pg1qicnsv0cj5ms9g9qs336cgd3"))))
     (build-system meson-build-system)
+    (outputs '("out" "doc"))
     (arguments
-     `(#:glib-or-gtk? #t))     ; To wrap binaries and/or compile schemas
+     `(#:glib-or-gtk? #t     ; To wrap binaries and/or compile schemas
+       #:configure-flags
+       (list
+        "-Ddocs=true"
+        "-Dman=true")
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'patch-docbook
+           (lambda* (#:key inputs #:allow-other-keys)
+             (with-directory-excursion "doc"
+               (substitute* (find-files "." "\\.xml$")
+                 (("http://www.oasis-open.org/docbook/xml/4\\.3/")
+                  (string-append (assoc-ref inputs "docbook-xml")
+                                 "/xml/dtd/docbook/")))
+               (substitute* "meson.build"
+                 (("http://docbook.sourceforge.net/release/xsl/current/")
+                  (string-append (assoc-ref inputs "docbook-xsl")
+                                 "/xml/xsl/docbook-xsl-1.79.2/"))))
+             #t))
+         (add-after 'install 'move-docs
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (doc (assoc-ref outputs "doc")))
+               (mkdir-p (string-append doc "/share"))
+               (rename-file
+                (string-append out "/share/gtk-doc")
+                (string-append doc "/share/gtk-doc"))
+               #t))))))
     (native-inputs
-     `(("gettext" ,gettext-minimal)
+     `(("docbook-xml" ,docbook-xml-4.3)
+       ("docbook-xsl" ,docbook-xsl)
+       ("gettext" ,gettext-minimal)
        ("glib" ,glib "bin")      ;for glib-mkenums and glib-genmarshal
        ("gobject-introspection" ,gobject-introspection)
-       ("pkg-config" ,pkg-config)))
+       ("gtk-doc" ,gtk-doc)
+       ("pkg-config" ,pkg-config)
+       ("xsltproc" ,libxslt)))
     (propagated-inputs
      `(("glib" ,glib)))                 ;according to json-glib-1.0.pc
     (home-page "https://wiki.gnome.org/Projects/JsonGlib")
-- 
2.31.0