diff mbox series

[bug#65483] Updating EternalTerminal

Message ID 30759e57065acfe35b3bbeae71ab090c90610e5a.1692838398.git.aaron.covrig.us@ieee.org
State New
Headers show
Series [bug#65483] Updating EternalTerminal | expand

Commit Message

Aaron Covrig Aug. 24, 2023, 12:53 a.m. UTC
Changes:
1. Updated EternalTerminal to the current latest release
(which fixes build issues)
2. Removed GoogleTest dependency from EternalTerminal as the
project has replaced it with Catch2
3. Added (gnu packages curl) to inclusions as EternalTerminal now
depends on curl
---
 gnu/packages/terminals.scm | 23 +++++++----------------
 1 file changed, 7 insertions(+), 16 deletions(-)


base-commit: 3ce3466311953cc5f00a4fb34ff094a9a3501399

Comments

Christopher Baines Oct. 20, 2023, 11:58 a.m. UTC | #1
Aaron Covrig via Guix-patches via <guix-patches@gnu.org> writes:

> Changes:
> 1. Updated EternalTerminal to the current latest release
> (which fixes build issues)
> 2. Removed GoogleTest dependency from EternalTerminal as the
> project has replaced it with Catch2
> 3. Added (gnu packages curl) to inclusions as EternalTerminal now
> depends on curl
> ---
>  gnu/packages/terminals.scm | 23 +++++++----------------
>  1 file changed, 7 insertions(+), 16 deletions(-)

Hi Aaron,

Thanks for the patch, I've written a commit message in the Guix style:

  gnu: eternalterminal: Update to 6.2.4.

  * gnu/packages/terminals.scm (eternalterminal): Update to 6.2.4.
  [arguments]: Add -DDISABLE_VCPKG=1 to #:configure-flags, remove #:phases.
  [inputs]: Remove gflags, add openssl, zlib and curl.
  [native-inputs]: Remove.

and pushed this to master now as
746298e54fddcd4f2f9b7a65355dd6b692f67a71.

Chris
diff mbox series

Patch

diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index c59b1a6588..624b845a58 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -74,6 +74,7 @@  (define-module (gnu packages terminals)
   #:use-module (gnu packages crates-io)
   #:use-module (gnu packages crates-graphics)
   #:use-module (gnu packages crypto)
+  #:use-module (gnu packages curl)
   #:use-module (gnu packages dlang)
   #:use-module (gnu packages docbook)
   #:use-module (gnu packages fontutils)
@@ -1301,30 +1302,20 @@  (define-public kitty
 (define-public eternalterminal
   (package
     (name "eternalterminal")
-    (version "6.0.13")
-    (source
+    (version "6.2.4")
+    (source 
       (origin
         (method git-fetch)
         (uri (git-reference
                (url "https://github.com/MisterTea/EternalTerminal")
                (commit (string-append "et-v" version))))
         (file-name (git-file-name name version))
-       (sha256
-        (base32 "0sb1hypg2276y8c2a5vivrkcxp70swddvhnd9h273if3kv6j879r"))))
+        (sha256
+          (base32 "13vhr701j85ga37d53339bxgrf9fqa6z1zcp6s3ly5bb8p7lyvzm"))))
     (build-system cmake-build-system)
     (arguments
-     '(#:configure-flags '("-DBUILD_TEST=ON")
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'insert-googletests
-           (lambda* (#:key inputs #:allow-other-keys)
-             (let ((tests (assoc-ref inputs "googletest")))
-               (copy-recursively tests "external/googletest"))
-             #t)))))
-    (inputs
-     (list gflags libsodium protobuf))
-    (native-inputs
-     `(("googletest" ,(package-source googletest))))
+     '(#:configure-flags '("-DBUILD_TEST=ON" "-DDISABLE_VCPKG=1")))
+    (inputs (list libsodium protobuf openssl zlib curl))
     (home-page "https://mistertea.github.io/EternalTerminal/")
     (synopsis "Remote shell that reconnects without interrupting the session")
     (description "@dfn{Eternal Terminal} (ET) is a remote shell that