diff mbox series

[bug#46075,liferea] : Update +

Message ID 303e0998-cdc5-8363-9004-43dc0e31a1dc@raghavgururajan.name
State New
Headers show
Series [bug#46075,liferea] : Update + | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Raghav Gururajan Jan. 24, 2021, 4:23 p.m. UTC

Comments

Efraim Flashner Jan. 28, 2021, 10:37 a.m. UTC | #1
I wasn't able to apply the upgrade to 1.13.5 patch, liferea wouldn't
build for me with the upgraded version.

Making check in po
make[1]: Entering directory '/tmp/guix-build-liferea-1.13.5.drv-0/source/po'
INTLTOOL_EXTRACT="/gnu/store/ddyxcvw6280hxwipyvzrlqsm6sv1irjc-intltool-0.51.0/bin/intltool-extract" XGETTEXT="/gnu/store/n9wx4dp68bfsw9bb1bwmklzl34ggrmgm-gettext-minimal-0.20.1/bin/xgettext" srcdir=. /gnu/store/ddyxcvw6280hxwipyvzrlqsm6sv1irjc-intltool-0.51.0/bin/intltool-update --gettext-package liferea --pot
rm -f missing notexist
srcdir=. /gnu/store/ddyxcvw6280hxwipyvzrlqsm6sv1irjc-intltool-0.51.0/bin/intltool-update -m
The following files contain translations and are currently not in use. Please
consider adding these to the POTFILES.in file, located in the po/ directory.

plugins/getfocus.py

If some of these files are left out on purpose then please add them to
POTFILES.skip instead of POTFILES.in. A file 'missing' containing this list
of left out files has been written in the current directory.
Please report to liferea-devel@lists.sourceforge.net
if [ -r missing -o -r notexist ]; then \
  exit 1; \
fi
make[1]: *** [Makefile:350: check] Error 1
make[1]: Leaving directory '/tmp/guix-build-liferea-1.13.5.drv-0/source/po'
make: *** [Makefile:711: check-recursive] Error 1

Test suite failed, dumping logs.
command "make" "check" "-j" "24" "gtk_update_icon_cache=true" failed with status 2
builder for `/gnu/store/f145f3mpdr0y12ybbhjs9inbbz90nl7q-liferea-1.13.5.drv' failed with exit code 1
build of /gnu/store/f145f3mpdr0y12ybbhjs9inbbz90nl7q-liferea-1.13.5.drv failed
View build log at '/var/log/guix/drvs/f1/45f3mpdr0y12ybbhjs9inbbz90nl7q-liferea-1.13.5.drv.bz2'.
guix build: error: build of `/gnu/store/f145f3mpdr0y12ybbhjs9inbbz90nl7q-liferea-1.13.5.drv' failed
diff mbox series

Patch

From a3a86c6d7ecfae79731efd0188ab41ad873e432e Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <rg@raghavgururajan.name>
Date: Sun, 24 Jan 2021 11:11:11 -0500
Subject: [PATCH 1/3] gnu: liferea: Add missing inputs.

These new inputs are referenced by the package but was missing in
the package definition. Some of these inputs might have been used
by the package indirectly via propagation from other inputs.

* gnu/packages/syndication.scm (liferea) [inputs]: Add glib, libsoup,
pango and sqlite.
---
 gnu/packages/syndication.scm | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/syndication.scm b/gnu/packages/syndication.scm
index 54fa221fa6..4a5c042309 100644
--- a/gnu/packages/syndication.scm
+++ b/gnu/packages/syndication.scm
@@ -222,7 +222,8 @@  file system, and many more features.")
        ("pkg-config" ,pkg-config)
        ("which" ,which)))
     (inputs
-     `(("glib-networking" ,glib-networking)
+     `(("glib" ,glib)
+       ("glib-networking" ,glib-networking)
        ("gnome-keyring" ,gnome-keyring)
        ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
        ("gstreamer" ,gstreamer)
@@ -230,11 +231,14 @@  file system, and many more features.")
        ("libnotify" ,libnotify)
        ("libpeas" ,libpeas)
        ("libsecret" ,libsecret)
+       ("libsoup" ,libsoup)
        ("libxml2" ,libxml2)
        ("libxslt" ,libxslt)
+       ("pango" ,pango)
        ("python" ,python)
        ("python-pycairo" ,python-pycairo)
        ("python-pygobject" ,python-pygobject)
+       ("sqlite" ,sqlite)
        ("webkitgtk" ,webkitgtk)))
     (home-page "https://lzone.de/liferea/")
     (synopsis "News reader for GTK/GNOME")
-- 
2.30.0