[bug#35218] Fix Lua dependencies of Neovim

Message ID 3027356.Ros9scuHIA@aleksandar-ixtreme-m5740
State Accepted
Headers show
Series [bug#35218] Fix Lua dependencies of Neovim | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

HiPhish April 10, 2019, 11:49 a.m. UTC
Lua minor version releases are not backwards-compatible and Neovim requires 
Lua 5.1, not the previously specified Lua 5.2 version.

Comments

Ludovic Courtès April 11, 2019, 11:34 a.m. UTC | #1
Hi,

HiPhish <hiphish@posteo.de> skribis:

> Lua minor version releases are not backwards-compatible and Neovim requires 
> Lua 5.1, not the previously specified Lua 5.2 version.

OK.

> From c878cc9d30a265bc97836e799b85ad41bc8a5e29 Mon Sep 17 00:00:00 2001
> From: HiPhish <hiphish@posteo.de>
> Date: Wed, 10 Apr 2019 13:21:26 +0200
> Subject: [PATCH] 2019-04-10  HiPhish <hiphish@posteo.de>
>
> * gnu/packages/vim.scm (neovim): Use correct Lua version as dependencies

I adjusted the subject line of the commit and applied it.  Thanks!

Ludo’.

Patch

From c878cc9d30a265bc97836e799b85ad41bc8a5e29 Mon Sep 17 00:00:00 2001
From: HiPhish <hiphish@posteo.de>
Date: Wed, 10 Apr 2019 13:21:26 +0200
Subject: [PATCH] 2019-04-10  HiPhish <hiphish@posteo.de>

* gnu/packages/vim.scm (neovim): Use correct Lua version as dependencies
---
 gnu/packages/vim.scm | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 56deb12c3d..dadffa3ab1 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -756,7 +756,7 @@  are detected, the user is notified.")))
              #t))
          (add-after 'unpack 'set-lua-paths
            (lambda* (#:key inputs #:allow-other-keys)
-             (let* ((lua-version "5.2")
+             (let* ((lua-version "5.1")
                     (lua-cpath-spec
                      (lambda (prefix)
                        (let ((path (string-append prefix "/lib/lua/" lua-version)))
@@ -783,10 +783,10 @@  are detected, the user is notified.")))
        ("unibilium" ,unibilium)
        ("jemalloc" ,jemalloc)
        ("libiconv" ,libiconv)
-       ("lua" ,lua-5.2)
-       ("lua-lpeg" ,lua5.2-lpeg)
-       ("lua-bitop" ,lua5.2-bitop)
-       ("lua-libmpack" ,lua5.2-libmpack)))
+       ("lua" ,lua-5.1)
+       ("lua-lpeg" ,lua5.1-lpeg)
+       ("lua-bitop" ,lua5.1-bitop)
+       ("lua-libmpack" ,lua5.1-libmpack)))
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("gettext" ,gettext-minimal)
-- 
2.19.1