diff mbox series

[bug#55235] gnu: Add touchegg.

Message ID 2qM0dQLMorblMzkWu4bOu8DZt2npNzfY9LN5Uh3Gbx82PczvoMoXpLLevtCATk4tAm7k67gTWCjgxvKF31UyMg_9EzX_KtJH8xwwNa-bpkM=@protonmail.com
State Accepted
Headers show
Series [bug#55235] gnu: Add touchegg. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Rene Saavedra May 20, 2022, 6:39 p.m. UTC
Hi,

> I will send an updated version of the package that works with a Shepherd service.
>

Attached the updated version of the package, I did tests executing Touchegg as a service (which I will send in another mail, WIP).


--
Rene

Comments

Julien Lepiller June 4, 2022, 3:56 p.m. UTC | #1
Le Fri, 20 May 2022 18:39:05 +0000,
Rene Saavedra via Guix-patches via <guix-patches@gnu.org> a écrit :

> Hi,
> 
> > I will send an updated version of the package that works with a
> > Shepherd service. 
> 
> Attached the updated version of the package, I did tests executing
> Touchegg as a service (which I will send in another mail, WIP).
> 
> 
> --
> Rene

Hi Rene,

pushed to master as 28274a353d3618784a4035e928db688f0664aa8c, thank you!
diff mbox series

Patch

From d05652739c98e0b25f73284cb286620102ab51ba Mon Sep 17 00:00:00 2001
From: Rene Saavedra <nanuui@protonmail.com>
Date: Fri, 20 May 2022 13:30:09 -0500
Subject: [PATCH] gnu: Add touchegg.

* gnu/packages/linux.scm (touchegg): New variable.
---
 gnu/packages/linux.scm | 40 ++++++++++++++++++++++++++++++++++++++++
 1 file changed, 40 insertions(+)

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index e179a5c2f7..38fa06e98b 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -61,6 +61,7 @@ 
 ;;; Copyright © 2021 Solene Rapenne <solene@perso.pw>
 ;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
 ;;; Copyright © 2022 Artyom V. Poptsov <poptsov.artyom@gmail.com>
+;;; Copyright © 2022 Rene Saavedra <nanuui@protonmail.com>
 
 ;;;
 ;;; This file is part of GNU Guix.
@@ -110,6 +111,7 @@  (define-module (gnu packages linux)
   #:use-module (gnu packages gcc)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages glib)
+  #:use-module (gnu packages gnome)
   #:use-module (gnu packages gnupg)
   #:use-module (gnu packages golang)
   #:use-module (gnu packages gperf)
@@ -9187,3 +9189,41 @@  (define-public libtree
      "This tool turns @command{ldd} into a tree and explains how shared
 libraries are found or why they cannot be located.")
     (license license:expat)))
+
+(define-public touchegg
+  (package
+    (name "touchegg")
+    (version "2.0.14")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/JoseExposito/touchegg")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0shvslz0c8nqx5f988z55qjc9xw0in9rb7b19r6vr1f7cdkqb6yr"))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:tests? #f ; No tests exist
+       #:configure-flags
+       (list "-DUSE_SYSTEMD=OFF"))) ; No systemd
+    (native-inputs
+     (list
+      pkg-config))
+    (inputs
+     (list
+      cairo
+      gtk+
+      libgudev
+      libinput
+      libxrandr
+      libxtst
+      pugixml))
+    (home-page "https://github.com/JoseExposito/touchegg")
+    (synopsis "Multitouch gesture recognizer")
+    (description
+     "Touchégg is an application that runs in the background and transform the
+gestures you make on your touchpad or touchscreen into visible actions in your
+desktop.")
+    (license license:gpl3+)))
-- 
2.36.0