[bug#58620] Update blur my shell
Commit Message
Comments
Am Mittwoch, dem 19.10.2022 um 04:25 +0000 schrieb Charles:
> [PATCH] gnu: gnome-shell-extensions: Update blur my shell to version
> 44.
Should be: "gnu: update gnome-shell-extension-blur-my-shell to 44".
>
> * gnu/packages/gnome-xyz.scm (gnome-shell-extension-blur-my-shell)
> Update version and hash. Add a phase to move the contents of the src
> and resources directories to project root so they get installed
> properly.
Break lines between changes and make clear what's changed. Use
indicators such as [#:phases].
> ---
> gnu/packages/gnome-xyz.scm | 31 ++++++++++++++++++++++---------
> 1 file changed, 22 insertions(+), 9 deletions(-)
>
> diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
> index 68166978a1..89bb9c9d7b 100644
> --- a/gnu/packages/gnome-xyz.scm
> +++ b/gnu/packages/gnome-xyz.scm
> @@ -996,7 +996,7 @@ (define-public gnome-shell-extension-burn-my-
> windows
> (define-public gnome-shell-extension-blur-my-shell
> (package
> (name "gnome-shell-extension-blur-my-shell")
> - (version "29")
> + (version "44")
> (source
> (origin
> (method git-fetch)
> @@ -1006,9 +1006,7 @@ (define-public gnome-shell-extension-blur-my-
> shell
> (file-name (git-file-name name version))
> (sha256
> (base32
> - "13x7zgaj3dz7lypdv1bgmpmh0f2w53q567zxmhmqimi1gy5mjrvk"))
> - (snippet
> - '(begin (delete-file "src/schemas/gschemas.compiled")))))
> + "0h7yfvrrg5r821mzrp42c09jws06mw6v9avvkfykqj8n8qnslmyx"))))
Why is the snippet removed?
> (build-system copy-build-system)
> (arguments
> `(#:install-plan
> @@ -1016,15 +1014,30 @@ (define-public gnome-shell-extension-blur-my-
> shell
> "share/gnome-shell/extensions/"
> "blur-my-shell@aunetx")
> #:include-regexp ("\\.js(on)?$" "\\.css$" "\\.ui$"
> "\\.png$"
> - "\\.xml$" "\\.compiled$")))
> + "\\.svg$" "\\.xml$" "\\.compiled$")))
Note the addition of "\\.svg$" in the ChangeLog.
> #:phases
> (modify-phases %standard-phases
> - (add-after 'unpack 'cd-src
> - (lambda _ (chdir "src")))
> - (add-before 'install 'compile-schemas
> + (add-after 'unpack 'compile-schemas
> (lambda _
> (with-directory-excursion "schemas"
> - (invoke "glib-compile-schemas" ".")))))))
> + (invoke "glib-compile-schemas" "."))))
> + (add-before 'install 'unpack-src
> + (lambda _
> + (use-modules (ice-9 ftw))
> + (define (explode-dir dir)
> + (for-each
> + (lambda (file)
> + (let ((full-file-name
> + (string-append (getcwd) "/" dir "/" file)))
> + (rename-file
> + full-file-name
> + (string-append (getcwd) "/" file))))
> + (filter (lambda (file)
> + (not (or (string=? file ".")
> + (string=? file ".."))))
> + (scandir (string-append (getcwd) "/"
> dir)))))
> + (explode-dir "src")
> + (explode-dir "resources"))))))
Adjust #:install-plan instead.
> (native-inputs
> (list (list glib "bin"))) ; for glib-compile-schemas
> (home-page "https://github.com/aunetx/blur-my-shell")
> --
Cheers
From 2fec71f98487e19f49c992a27a55d00ac5821662 Mon Sep 17 00:00:00 2001
From: Charles <charles.b.jackson@protonmail.com>
Date: Tue, 18 Oct 2022 23:04:24 -0500
Subject: [PATCH] gnu: gnome-shell-extensions: Update blur my shell to version
44.
* gnu/packages/gnome-xyz.scm (gnome-shell-extension-blur-my-shell) Update
version and hash. Add a phase to move the contents of the src and resources
directories to project root so they get installed properly.
---
gnu/packages/gnome-xyz.scm | 31 ++++++++++++++++++++++---------
1 file changed, 22 insertions(+), 9 deletions(-)
@@ -996,7 +996,7 @@ (define-public gnome-shell-extension-burn-my-windows
(define-public gnome-shell-extension-blur-my-shell
(package
(name "gnome-shell-extension-blur-my-shell")
- (version "29")
+ (version "44")
(source
(origin
(method git-fetch)
@@ -1006,9 +1006,7 @@ (define-public gnome-shell-extension-blur-my-shell
(file-name (git-file-name name version))
(sha256
(base32
- "13x7zgaj3dz7lypdv1bgmpmh0f2w53q567zxmhmqimi1gy5mjrvk"))
- (snippet
- '(begin (delete-file "src/schemas/gschemas.compiled")))))
+ "0h7yfvrrg5r821mzrp42c09jws06mw6v9avvkfykqj8n8qnslmyx"))))
(build-system copy-build-system)
(arguments
`(#:install-plan
@@ -1016,15 +1014,30 @@ (define-public gnome-shell-extension-blur-my-shell
"share/gnome-shell/extensions/"
"blur-my-shell@aunetx")
#:include-regexp ("\\.js(on)?$" "\\.css$" "\\.ui$" "\\.png$"
- "\\.xml$" "\\.compiled$")))
+ "\\.svg$" "\\.xml$" "\\.compiled$")))
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'cd-src
- (lambda _ (chdir "src")))
- (add-before 'install 'compile-schemas
+ (add-after 'unpack 'compile-schemas
(lambda _
(with-directory-excursion "schemas"
- (invoke "glib-compile-schemas" ".")))))))
+ (invoke "glib-compile-schemas" "."))))
+ (add-before 'install 'unpack-src
+ (lambda _
+ (use-modules (ice-9 ftw))
+ (define (explode-dir dir)
+ (for-each
+ (lambda (file)
+ (let ((full-file-name
+ (string-append (getcwd) "/" dir "/" file)))
+ (rename-file
+ full-file-name
+ (string-append (getcwd) "/" file))))
+ (filter (lambda (file)
+ (not (or (string=? file ".")
+ (string=? file ".."))))
+ (scandir (string-append (getcwd) "/" dir)))))
+ (explode-dir "src")
+ (explode-dir "resources"))))))
(native-inputs
(list (list glib "bin"))) ; for glib-compile-schemas
(home-page "https://github.com/aunetx/blur-my-shell")
--
2.38.0