diff mbox series

[bug#64909,vREVISION] gnu: godot: Use system brotli

Message ID 2ff9cfb9e606cd4c359e980fcb5d2a47cb2a9279.1690518397.git.takev@disroot.org
State New
Headers show
Series [bug#64909,vREVISION] gnu: godot: Use system brotli | expand

Commit Message

TakeV July 28, 2023, 4:26 a.m. UTC
* gnu/packages/game-development.scm (godot) [arguments,inputs]: use system brotli
---
 gnu/packages/game-development.scm | 6 ++----
 1 file changed, 2 insertions(+), 4 deletions(-)


base-commit: 35c8d631d2bd63c64e863b5509f29fdcb7f856e6

Comments

Liliana Marie Prikler July 30, 2023, 6:57 a.m. UTC | #1
Am Donnerstag, dem 27.07.2023 um 21:26 -0700 schrieb TakeV:
> * gnu/packages/game-development.scm (godot) [arguments,inputs]: use
> system brotli
> ---

In case someone else wants to push this, the proper message (minus
leading spaces and missing sign-off) would be:

    gnu: godot: Use system brotli.
    
    * gnu/packages/game-development.scm (godot)[source]: Do not preserve brotli.
    [arguments]<#:scons-flags>: Add “builtin_brotli=no”.
    [inputs]: Add brotli.

Otherwise, I'm queuing this for Saturday.

Cheers
Liliana Marie Prikler Aug. 5, 2023, 12:37 p.m. UTC | #2
Am Sonntag, dem 30.07.2023 um 08:57 +0200 schrieb Liliana Marie
Prikler:
> Am Donnerstag, dem 27.07.2023 um 21:26 -0700 schrieb TakeV:
> > * gnu/packages/game-development.scm (godot) [arguments,inputs]: use
> > system brotli
> > ---
> 
> In case someone else wants to push this, the proper message (minus
> leading spaces and missing sign-off) would be:
> 
>     gnu: godot: Use system brotli.
>     
>     * gnu/packages/game-development.scm (godot)[source]: Do not
> preserve brotli.
>     [arguments]<#:scons-flags>: Add “builtin_brotli=no”.
>     [inputs]: Add brotli.
> 
> Otherwise, I'm queuing this for Saturday.
queue.pop (this);

Cheers
diff mbox series

Patch

diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 127cbac127..84bbd68cce 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -2017,10 +2017,6 @@  (define-public godot
                               "assimp"
                               "astcenc"
                               "basis_universal"
-                              ;; TODO: Can unbundle once
-                              ;; <https://github.com/godotengine/godot/pull/79101>
-                              ;; is merged
-                              "brotli"
                               ;; Godot needs ca-certificates.crt, but that is
                               ;; not available in build environment
                               "certs"
@@ -2067,6 +2063,7 @@  (define-public godot
                         "use_volk=no"
                         ;; Avoid using many of the bundled libs.
                         ;; Note: These options can be found in the SConstruct file.
+                        "builtin_brotli=no"
                         "builtin_embree=no"
                         "builtin_enet=no"
                         "builtin_freetype=no"
@@ -2193,6 +2190,7 @@  (define-public godot
      (list pkg-config))
     (inputs
      (list alsa-lib
+           brotli
            dbus
            embree
            enet