diff mbox series

[bug#71001] gnu: libwacom: Update to 2.11.0.

Message ID 2f9068a109d5c9899fcb4a8285b02951bef05428.1715943457.git.dariqq@posteo.net
State New
Headers show
Series [bug#71001] gnu: libwacom: Update to 2.11.0. | expand

Commit Message

Dariqq May 17, 2024, 10:57 a.m. UTC
With the 2.9 release the license got clarified to be hpnd.

* gnu/packages/xdisorg.scm (libwacom): Update to 2.11.0.
[#:phases]: Add a phase to wrap with GUIX_PYTHONPATH.
[native-inputs]: Remove python-evdev.
[inputs]: Add bash-minimal, python, python-libevdev, python-pyudev.
[propagated-inputs]: Add libevdev.
[license]: Correct license to hpnd.

Change-Id: Ib5276beaec2c23e74532cb157225fc3a9a2e25e7
---

Hi Guix,
This patch updates the libwacom package.
The license was wrong before and upstream now clarified that it is hpnd.
The license file does not get installed right now, I've opened #70999 as this is a general problem with meson-build-system.
The libwacom.pc file now also requires libevdev so I added that as a propagated input. 
I've also added a wrapper with pythonpath for the python program.

 gnu/packages/xdisorg.scm | 25 ++++++++++++++++++-------
 1 file changed, 18 insertions(+), 7 deletions(-)


base-commit: 0846eaecd45783bf40e8dc67b0c16f71068524b7
diff mbox series

Patch

diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index e13b44290e..f8ef28d5fa 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -1449,7 +1449,7 @@  (define-public xcape
 (define-public libwacom
   (package
     (name "libwacom")
-    (version "2.6.0")
+    (version "2.11.0")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -1457,24 +1457,35 @@  (define-public libwacom
                     "libwacom-" version "/libwacom-" version ".tar.xz"))
               (sha256
                (base32
-                "13x978gzyw28cqd985m5smiqgza0xp3znb1s0msmn8vmjjlwqxi3"))))
+                "0i0k333kfc6ai4vxqijjybj38s9j1hly2x327113lm1cr0g9jgxh"))))
     (build-system meson-build-system)
     (arguments
      (list
-      #:configure-flags #~(list "--default-library=shared")))
+      #:configure-flags #~(list "--default-library=shared")
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'install 'wrap-program
+            (lambda* _
+              (wrap-program (string-append #$output "/bin/libwacom-show-stylus")
+                `("GUIX_PYTHONPATH" prefix (,(getenv "GUIX_PYTHONPATH")))))))))
     (native-inputs
      (list pkg-config
            ;; For tests.
            python
-           python-evdev
            python-libevdev
            python-pytest
            python-pyudev))
     (inputs
-     (list gtk+ eudev libxml2))
+     (list bash-minimal ;; for wrap-program
+           gtk+
+           eudev
+           libxml2
+           python
+           python-libevdev
+           python-pyudev))
     (propagated-inputs
      ;; libwacom.pc 'Requires' these:
-     (list glib libgudev))
+     (list glib libevdev libgudev))
     (home-page "https://linuxwacom.github.io/")
     (synopsis "Helper library for graphics tablet settings")
     (description
@@ -1482,7 +1493,7 @@  (define-public libwacom
 intended to be used by client-programs that need model identification.  It is
 already being used by the gnome-settings-daemon and the GNOME Control Center
 Wacom tablet applet.")
-    (license license:x11)))
+    (license license:hpnd)))
 
 (define-public xf86-input-wacom
   (package