diff mbox series

[bug#63903,v2,09/11] gnu: Add go-github-com-matrix-org-gomatrix.

Message ID 2f7ad72f39258c928c849409f4c502ffc14009ec.1685973062.git.hako@ultrarare.space
State New
Headers show
Series gnu: Add miniflux. | expand

Commit Message

Hilton Chain June 5, 2023, 1:52 p.m. UTC
* gnu/packages/golang.scm (go-github-com-matrix-org-gomatrix): New variable.
---
 gnu/packages/golang.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index d8c20d2725..10c2e46670 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5484,6 +5484,27 @@  (define-public go-gopkg-in-yaml-v3
 1.1 for backwards compatibility.")
     (license license:asl2.0)))
 
+(define-public go-github-com-matrix-org-gomatrix
+  (package
+    (name "go-github-com-matrix-org-gomatrix")
+    (version "0.0.0-20220926102614-ceba4d9f7530")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/matrix-org/gomatrix")
+                    (commit (go-version->git-ref version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0vq29bdswvffxsmwvi20wnk73xk92dva0fdr2k3zshr4z10ypm2x"))))
+    (build-system go-build-system)
+    (arguments
+     (list #:import-path "github.com/matrix-org/gomatrix"))
+    (home-page "https://github.com/matrix-org/gomatrix")
+    (synopsis "Golang Matrix client")
+    (description "This package provides a Golang Matrix client.")
+    (license license:asl2.0)))
+
 (define-public go-github-com-mattn-go-isatty
   (package
     (name "go-github-com-mattn-go-isatty")