[bug#77006,1/3] gnu: Add python-flexcache.

Message ID 2f51d65864c1302eeca755c41a54a5f18c87d921.1741938583.git.lars.bilke@ufz.de
State New
Headers
Series Update python-pint to 0.24.4 |

Commit Message

Lars Bilke March 14, 2025, 7:52 a.m. UTC
  * gnu/packages/python-xyz.scm (python-flexcache): New variable.

Change-Id: Ib583c2a7fcdfde7f06307f91ecd0e500426d3a7d
---
 gnu/packages/python-xyz.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
  

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index cf1b5e22ae..6a38332021 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2095,6 +2095,33 @@  (define-public python-pymdown-extensions
 Markdown.  All extensions are found under the module namespace of pymdownx.")
     (license license:expat)))
 
+(define-public python-flexcache
+  (package
+    (name "python-flexcache")
+    (version "0.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "flexcache" version))
+       (sha256
+        (base32 "0mh6c3s0ykmnnhzys72xq5ls4myzpz1y86fmz0ngw6v2l3aknx0q"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-typing-extensions))
+    (native-inputs (list python-pytest
+                         python-pytest-cov
+                         python-pytest-mpl
+                         python-pytest-subtests
+                         python-setuptools
+                         python-setuptools-scm
+                         python-wheel))
+    (home-page "https://github.com/hgrecco/flexcache")
+    (synopsis
+     "Caching transformed versions of a source object")
+    (description
+     "A robust and extensible package to cache on disk the result of
+expensive calculations.")
+    (license license:bsd-3)))
+
 (define-public python-pint
   (package
     (name "python-pint")