[bug#77398] gnu: xrdp: Update to 0.10.3, xorgxrdp: Update to 0.10.4.

Message ID 2f17180041e0fa52a8fe2081616e2865f8f29cd1.1743396418.git.atai@atai.org
State New
Headers
Series [bug#77398] gnu: xrdp: Update to 0.10.3, xorgxrdp: Update to 0.10.4. |

Commit Message

Andy Tai March 31, 2025, 4:47 a.m. UTC
  * gnu/packages/rdesktop.scm (xrdp): Update to 0.10.3.
[inputs]: Replace fuse-2 with fuse.
* gnu/packages/rdesktop.scm (xorgxrdp): Update to 0.10.4.

Change-Id: I581b8f75c25642d054bcdf22a325b67a1c47c73e
---
 gnu/packages/rdesktop.scm | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)


base-commit: 8c43056aabc2d22da61dc86049b143f7ae1ef516
  

Comments

Andreas Enge April 1, 2025, 11:03 a.m. UTC | #1
Hello Andy,

the patch fails on 32 bit according to QA:
   https://qa.guix.gnu.org/issue/77398/package-changes?i686-linux-change=broken&i686-linux-change=still-failing&i686-linux-change=unknown-to-failing&i686-linux-change=new-failing

The somewhat surprising error message in
   https://bordeaux.guix.gnu.org/build/cb17cf76-2ea0-4a1e-b19f-2f7220cc4a8a/log
is:
In file included from /gnu/store/83yp83mwzvdqn0qhr7hvs5cvizrcf76a-fuse-3.10.5/include/fuse3/fuse_lowlevel.h:25,
                 from chansrv_fuse.c:155:
/gnu/store/83yp83mwzvdqn0qhr7hvs5cvizrcf76a-fuse-3.10.5/include/fuse3/fuse_common.h:853:1: error: static assertion failed: "fuse: off_t must be 64bit"
  853 | _Static_assert(sizeof(off_t) == 8, "fuse: off_t must be 64bit");

Does this mean that fuse@3 only works on 64 bit platforms?
In any case, going back to fuse@2 will probably solve the problem.

Then I would suggest to write two commits for the two separate projects.

Thanks!

Andreas
  
Andy Tai April 1, 2025, 9:40 p.m. UTC | #2
OK I will take a look.  I think xrdp switched to fuse 3 in this release...
I need to check if 32-bit support is dropped

On Tue, Apr 1, 2025 at 4:04 AM Andreas Enge <andreas@enge.fr> wrote:

> Hello Andy,
>
> the patch fails on 32 bit according to QA:
>
> https://qa.guix.gnu.org/issue/77398/package-changes?i686-linux-change=broken&i686-linux-change=still-failing&i686-linux-change=unknown-to-failing&i686-linux-change=new-failing
>
> The somewhat surprising error message in
>
> https://bordeaux.guix.gnu.org/build/cb17cf76-2ea0-4a1e-b19f-2f7220cc4a8a/log
> is:
> In file included from
> /gnu/store/83yp83mwzvdqn0qhr7hvs5cvizrcf76a-fuse-3.10.5/include/fuse3/fuse_lowlevel.h:25,
>                  from chansrv_fuse.c:155:
> /gnu/store/83yp83mwzvdqn0qhr7hvs5cvizrcf76a-fuse-3.10.5/include/fuse3/fuse_common.h:853:1:
> error: static assertion failed: "fuse: off_t must be 64bit"
>   853 | _Static_assert(sizeof(off_t) == 8, "fuse: off_t must be 64bit");
>
> Does this mean that fuse@3 only works on 64 bit platforms?
> In any case, going back to fuse@2 will probably solve the problem.
>
> Then I would suggest to write two commits for the two separate projects.
>
> Thanks!
>
> Andreas
>
>
  
Andy Tai April 2, 2025, 5:52 a.m. UTC | #3
For info, xrdp 0.10.2 moved to fuse 3 https://c-nergy.be/blog/?p=20148
so the change to fuse for input should be correct..

On Tue, Apr 1, 2025 at 2:40 PM Andy Tai <atai@atai.org> wrote:
>
> OK I will take a look.  I think xrdp switched to fuse 3 in this release... I need to check if 32-bit support is dropped
>
> On Tue, Apr 1, 2025 at 4:04 AM Andreas Enge <andreas@enge.fr> wrote:
>>
>> Hello Andy,
>>
>> the patch fails on 32 bit according to QA:
>>    https://qa.guix.gnu.org/issue/77398/package-changes?i686-linux-change=broken&i686-linux-change=still-failing&i686-linux-change=unknown-to-failing&i686-linux-change=new-failing
>>
>> The somewhat surprising error message in
>>    https://bordeaux.guix.gnu.org/build/cb17cf76-2ea0-4a1e-b19f-2f7220cc4a8a/log
>> is:
>> In file included from /gnu/store/83yp83mwzvdqn0qhr7hvs5cvizrcf76a-fuse-3.10.5/include/fuse3/fuse_lowlevel.h:25,
>>                  from chansrv_fuse.c:155:
>> /gnu/store/83yp83mwzvdqn0qhr7hvs5cvizrcf76a-fuse-3.10.5/include/fuse3/fuse_common.h:853:1: error: static assertion failed: "fuse: off_t must be 64bit"
>>   853 | _Static_assert(sizeof(off_t) == 8, "fuse: off_t must be 64bit");
  
Andreas Enge April 2, 2025, 10:34 a.m. UTC | #4
The CFLAGS did work, nice! I have pushed and am closing the issue.

Thanks,

Andreas
  

Patch

diff --git a/gnu/packages/rdesktop.scm b/gnu/packages/rdesktop.scm
index d5d49edc200..d7a105f4c27 100644
--- a/gnu/packages/rdesktop.scm
+++ b/gnu/packages/rdesktop.scm
@@ -168,7 +168,7 @@  (define-public freerdp
 (define-public xrdp
   (package
     (name "xrdp")
-    (version "0.10.1")
+    (version "0.10.3")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -176,10 +176,10 @@  (define-public xrdp
                     version "/xrdp-" version ".tar.gz"))
               (sha256
                (base32
-                "10rgc9bfharwj7bq5k4qp4x00w214h6c6f861zi301h84125ylx2"))))
+                "15nhfh8lxwf0jlmq6knh3851sp6njps9nhl8n2867il7mcr9gmsj"))))
     (build-system gnu-build-system)
     (inputs (list check
-                  fuse-2
+                  fuse
                   imlib2
                   lame
                   libjpeg-turbo
@@ -234,7 +234,7 @@  (define-public xrdp
 (define-public xorgxrdp
   (package
     (name "xorgxrdp")
-    (version "0.10.2")
+    (version "0.10.4")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -243,7 +243,7 @@  (define-public xorgxrdp
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1dcxn0v88426j4n7irhy6h3qb21202v5xs1vr7j8xvs3sxihc2f7"))))
+                "0y243h7mk9jy5yrdgngjkcr6rzq4116ip7pvc6vwz7yfnxxd9v2f"))))
     (build-system gnu-build-system)
     (inputs (list check
                   imlib2