diff mbox series

[bug#71581,08/10] gnu: Remove node-binary-search-bootstrap.

Message ID 2f0f201865550795fc16cd72983e333aa56d6557.1718714173.git.ashvithshetty10@gmail.com
State New
Headers show
Series [bug#71581,01/10] gnu: llhttp-bootstrap: Update to 6.1.0. | expand

Commit Message

Ashvith Shetty June 18, 2024, 12:38 p.m. UTC
* gnu/packages/node.scm (node-binary-search-bootstrap): Delete variable.

Change-Id: I10402c840ed794d0bfba17a4033454de8a06a170
---
 gnu/packages/node.scm | 29 -----------------------------
 1 file changed, 29 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/node.scm b/gnu/packages/node.scm
index 806f33533a..33f868e84e 100644
--- a/gnu/packages/node.scm
+++ b/gnu/packages/node.scm
@@ -368,35 +368,6 @@  (define-public node-ms-bootstrap
 formats to milliseconds.")
     (license license:expat)))
 
-(define-public node-binary-search-bootstrap
-  (package
-    (name "node-binary-search")
-    (version "1.3.6")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/darkskyapp/binary-search.git")
-             (commit (string-append "v" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32
-         "1xr2msdc143cd3xwgq7n3rhzy7j8wrnaidxl0r6l6b6g3mpbpjig"))))
-    (build-system node-build-system)
-    (arguments
-     `(#:node ,node-bootstrap
-       #:tests? #f
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'patch-dependencies 'delete-dependencies
-           (lambda args
-             (delete-dependencies `("chai" "mocha")))))))
-    (home-page "https://github.com/darkskyapp/binary-search#readme")
-    (properties '((hidden? . #t)))
-    (synopsis "Tiny binary search function with comparators")
-    (description "This package is a binary search function for Node.js.")
-    (license license:cc0)))
-
 (define-public llhttp-bootstrap
   (package
     (inherit llhttp)