diff mbox series

[bug#38876] gnu: Add libmediaart.

Message ID 2ee7252de22c400891d49a9df12974578f4f9d34.camel@disroot.org
State Accepted
Headers show
Series [bug#38876] gnu: Add libmediaart. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Raghav Gururajan Jan. 2, 2020, 7:38 p.m. UTC
Hello Guix!

Please find the attached patch to add libmediaart.

Regards,
RG.
diff mbox series

Patch

From 4806e60aab8ea83d126639003106a06575f96159 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Thu, 2 Jan 2020 14:34:03 -0500
Subject: [PATCH] gnu: Add libmediaart.

* gnu/packages/gnome.scm (libmediaart): New variable.
---
 gnu/packages/gnome.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 036547f471..2be796db4d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -246,6 +246,33 @@  Desktop.  It is designed to be as simple as possible and has some unique
 features to enable users to create their discs easily and quickly.")
     (license license:gpl2+)))
 
+(define-public libmediaart
+  (package
+    (name "libmediaart")
+    (version "1.9.4")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://gnome/sources/" name "/"
+                                  (version-major+minor version) "/"
+                                  name "-" version ".tar.xz"))
+              (sha256
+               (base32
+                "0gc10imyabk57ar54m0qzms0x9dnmkymhkzyk8w1aj3y4lby0yx5"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("gdk-pixbuf" ,gdk-pixbuf)
+       ("gettext" ,gettext-minimal)
+       ("glib:bin" ,glib "bin")
+       ("gobject-introspection" ,gobject-introspection)
+       ("gtk+:doc", gtk+ "doc")
+       ("pkg-config" ,pkg-config)
+       ("vala" ,vala)))
+    (synopsis "Media Art library for GNOME desktop")
+    (description "Library tasked with managing, extracting and
+handling media art caches.")
+    (home-page "https://gitlab.gnome.org/GNOME/libmediaart")
+    (license license:gpl2+)))
+
 (define-public gnome-menus
   (package
     (name "gnome-menus")
-- 
2.24.1