diff mbox series

[bug#66842,03/39] gnu: Add rust-shellexpand-3.

Message ID 2ee378f5063662a6fd9b1297f33e22f0cd1bfaaa.1698720459.git.jaeme@runbox.com
State New
Headers show
Series Add macchina | expand

Commit Message

Jaeme Sifat Oct. 31, 2023, 2:52 a.m. UTC
* gnu/packages/crates-io.scm (rust-shellexpand-3): New variable.

Change-Id: I153d86db8c98f6c53ccaa8653b12c3d69573983c
---
 gnu/packages/crates-io.scm | 25 +++++++++++++++++++++----
 1 file changed, 21 insertions(+), 4 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index a4828d6eab..167d5ee5e0 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -65782,20 +65782,22 @@  (define-public rust-shell-words-0.1
        (sha256
         (base32 "0jnrw3f174974fsi2hg48l0klpy24767ib28w0xcvi2ll5axxb1r"))))))
 
-(define-public rust-shellexpand-2
+(define-public rust-shellexpand-3
   (package
     (name "rust-shellexpand")
-    (version "2.1.2")
+    (version "3.1.0")
     (source
      (origin
        (method url-fetch)
        (uri (crate-uri "shellexpand" version))
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
-        (base32 "1r0i1r2r3dv0rc82xc5vhxmwl3zbvblf91sgmwls0k8chiv81k3w"))))
+        (base32 "0jz1i14ziz8gbyj71212s7dqrw6q96f25i48zkmy66fcjhxzl0ys"))))
     (build-system cargo-build-system)
     (arguments
-     `(#:cargo-inputs (("rust-dirs" ,rust-dirs-4))))
+     `(#:cargo-inputs (("rust-bstr" ,rust-bstr-1)
+                       ("rust-dirs" ,rust-dirs-5)
+                       ("rust-os-str-bytes" ,rust-os-str-bytes-6))))
     (home-page "https://github.com/netvl/shellexpand")
     (synopsis "Shell-like expansions in strings")
     (description
@@ -65806,6 +65808,21 @@  (define-public rust-shellexpand-2
 some context).")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-shellexpand-2
+  (package
+    (inherit rust-shellexpand-3)
+    (name "rust-shellexpand")
+    (version "2.1.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "shellexpand" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1r0i1r2r3dv0rc82xc5vhxmwl3zbvblf91sgmwls0k8chiv81k3w"))))
+    (arguments
+     `(#:cargo-inputs (("rust-dirs" ,rust-dirs-4))))))
+
 (define-public rust-shlex-1
   (package
     (name "rust-shlex")