[bug#75668] gnu: snapper: Update to 0.12.1.

Message ID 2e8ee4ce4f54383b37633f27329d502c3dfe6bd2.1737282248.git.ashish.is@lostca.se
State New
Headers
Series [bug#75668] gnu: snapper: Update to 0.12.1. |

Commit Message

Alexis Praga via Guix-patches via Jan. 19, 2025, 10:24 a.m. UTC
  From: Ashish SHUKLA <ashish.is@lostca.se>

* gnu/packages/file-systems.scm (snapper): Update to 0.12.1.
[#:phases]<relative-file-locations>: Update to patch more files.

Change-Id: I6ee16a4fca78a26a7c41e29f53c22ac51912e095
---
 gnu/packages/file-systems.scm | 10 ++++++----
 1 file changed, 6 insertions(+), 4 deletions(-)


base-commit: dbe1711a3a8aa4d6e1bef8285270e07579a74f19
  

Comments

Zheng Junjie Jan. 27, 2025, 3:42 a.m. UTC | #1
"ashish.is--- via Guix-patches" via <guix-patches@gnu.org> writes:

> From: Ashish SHUKLA <ashish.is@lostca.se>
>
> * gnu/packages/file-systems.scm (snapper): Update to 0.12.1.
> [#:phases]<relative-file-locations>: Update to patch more files.
>
> Change-Id: I6ee16a4fca78a26a7c41e29f53c22ac51912e095
> ---
>  gnu/packages/file-systems.scm | 10 ++++++----
>  1 file changed, 6 insertions(+), 4 deletions(-)
>
> diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
> index 937bff4375..50fe00f688 100644
> --- a/gnu/packages/file-systems.scm
> +++ b/gnu/packages/file-systems.scm
> @@ -1349,7 +1349,7 @@ (define-public apfs-fuse
>  (define-public snapper
>    (package
>      (name "snapper")
> -    (version "0.10.7")
> +    (version "0.12.1")
>      (source
>       (origin
>         (method git-fetch)
> @@ -1358,7 +1358,7 @@ (define-public snapper
>               (commit (string-append "v" version))))
>         (file-name (git-file-name name version))
>         (sha256
> -        (base32 "0nwmyzjwid1lf29dsr6w72dr781c81xyrjpk5y3scn4r55b5df0h"))
> +        (base32 "1i5623cnhzivf64zr0g1nlyn9sjgabhyawhpsffykdxvcrnyqn69"))
>         (modules '((guix build utils)))
>         (snippet
>          '(begin
> @@ -1375,8 +1375,10 @@ (define-public snapper
>                          (add-after 'unpack 'relative-file-locations
>                            (lambda* (#:key outputs #:allow-other-keys)
>                              (let* ((out (assoc-ref outputs "out")))
> -                              (substitute* (list "scripts/Makefile.am"
> -                                                 "data/Makefile.am")
> +                              (substitute* '("scripts/Makefile.am"
> +                                             "client/systemd-helper/Makefile.am"
> +                                             "client/installation-helper/Makefile.am"
> +                                             "data/Makefile.am")
>                                  (("/usr/share")
>                                   (string-append out "/share"))
>                                  (("/usr/lib")
>
> base-commit: dbe1711a3a8aa4d6e1bef8285270e07579a74f19
pushed, closing.
  

Patch

diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index 937bff4375..50fe00f688 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -1349,7 +1349,7 @@  (define-public apfs-fuse
 (define-public snapper
   (package
     (name "snapper")
-    (version "0.10.7")
+    (version "0.12.1")
     (source
      (origin
        (method git-fetch)
@@ -1358,7 +1358,7 @@  (define-public snapper
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0nwmyzjwid1lf29dsr6w72dr781c81xyrjpk5y3scn4r55b5df0h"))
+        (base32 "1i5623cnhzivf64zr0g1nlyn9sjgabhyawhpsffykdxvcrnyqn69"))
        (modules '((guix build utils)))
        (snippet
         '(begin
@@ -1375,8 +1375,10 @@  (define-public snapper
                         (add-after 'unpack 'relative-file-locations
                           (lambda* (#:key outputs #:allow-other-keys)
                             (let* ((out (assoc-ref outputs "out")))
-                              (substitute* (list "scripts/Makefile.am"
-                                                 "data/Makefile.am")
+                              (substitute* '("scripts/Makefile.am"
+                                             "client/systemd-helper/Makefile.am"
+                                             "client/installation-helper/Makefile.am"
+                                             "data/Makefile.am")
                                 (("/usr/share")
                                  (string-append out "/share"))
                                 (("/usr/lib")