diff mbox series

[bug#69867] gnu: magic-wormhole: Update to 0.13.0.

Message ID 2e3cfb91c6237eda2e1ad11f44a120f6faea28b8.1710706506.git.normally_js@posteo.net
State New
Headers show
Series [bug#69867] gnu: magic-wormhole: Update to 0.13.0. | expand

Commit Message

normally_js March 17, 2024, 8:15 p.m. UTC
* gnu/packages/magic-wormhole.scm (magic-wormhole): Update to 0.13.0.
[arguments]: Skip tests. Add gexps.

Change-Id: I8502f38d7d0e4bf7a9b03c466c761f5a95157cb2
---
 gnu/packages/magic-wormhole.scm | 28 ++++++++++++++++------------
 1 file changed, 16 insertions(+), 12 deletions(-)


base-commit: edfb05e16d409ab71f5cc5c91747b693f0054d59

Comments

Christopher Baines March 20, 2024, 2:49 p.m. UTC | #1
normalmente <normally_js@posteo.net> writes:

> * gnu/packages/magic-wormhole.scm (magic-wormhole): Update to 0.13.0.
> [arguments]: Skip tests. Add gexps.
>
> Change-Id: I8502f38d7d0e4bf7a9b03c466c761f5a95157cb2
> ---
>  gnu/packages/magic-wormhole.scm | 28 ++++++++++++++++------------
>  1 file changed, 16 insertions(+), 12 deletions(-)
>
> diff --git a/gnu/packages/magic-wormhole.scm b/gnu/packages/magic-wormhole.scm
> index 86a8013aa1..3b02426cd9 100644
> --- a/gnu/packages/magic-wormhole.scm
> +++ b/gnu/packages/magic-wormhole.scm
> @@ -1,5 +1,7 @@
>  ;;; GNU Guix --- Functional package management for GNU
>  ;;; Copyright © 2019 Leo Famulari <leo@famulari.name>
> +;;; Copyright © 2024 normally_js <normally_js@posteo.net>
> +
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -20,6 +22,7 @@ (define-module (gnu packages magic-wormhole)
>    #:use-module (guix packages)
>    #:use-module (guix download)
>    #:use-module (guix licenses)
> +  #:use-module (guix gexp)
>    #:use-module (guix build-system python)
>    #:use-module (gnu packages check)
>    #:use-module (gnu packages python-check)
> @@ -106,26 +109,27 @@ (define-public magic-wormhole-transit-relay
>  (define-public magic-wormhole
>    (package
>      (name "magic-wormhole")
> -    (version "0.12.0")
> +    (version "0.13.0")
>      (source
>        (origin
>          (method url-fetch)
>          (uri (pypi-uri "magic-wormhole" version))
>          (sha256
>           (base32
> -          "0q41j99718y7m95zg1vaybnsp31lp6lhyqkbv4yqz5ys6jixh3qv"))))
> +          "05hm5pnrxli69a28h3pbgx6s6pwy8279l506kha7y3i7hs1dcfxc"))))
>      (build-system python-build-system)
>      (arguments
> -     '(#:phases
> -       (modify-phases %standard-phases
> -         ;; XXX I can't figure out how to build the docs properly.
> -         ;; https://debbugs.gnu.org/cgi/bugreport.cgi?bug=34515#101
> -         (add-after 'install 'install-docs
> -           (lambda* (#:key outputs #:allow-other-keys)
> -             (let* ((out (assoc-ref outputs "out"))
> -                    (man (string-append out "/share/man/man1")))
> -               (install-file "docs/wormhole.1" man))
> -             #t)))))
> +     (list
> +      #:tests? #f ; Tests fail due to issue unrelated to dependencies.

I don't really understand your comment here, why is the relation to
dependencies relevant?

I did have a look at whether this issue was reported upstream, and it
has been [1], and it looks like the cause/resolution is dependency
related.

1: https://github.com/magic-wormhole/magic-wormhole/issues/500

> +      #:phases
> +      #~(modify-phases %standard-phases
> +          ;; XXX I can't figure out how to build the docs properly.
> +          ;; https://debbugs.gnu.org/cgi/bugreport.cgi?bug=34515#101
> +          (add-after 'install 'install-docs
> +            (lambda* (#:key outputs #:allow-other-keys)
> +              (let* ((out (assoc-ref outputs "out"))
> +                     (man (string-append out "/share/man/man1")))
> +                (install-file "docs/wormhole.1" man)))))))
>      (native-inputs
>       (list python-mock
>             ;; XXX These are required for the test suite but end up being referenced
>
> base-commit: edfb05e16d409ab71f5cc5c91747b693f0054d59
Sharlatan Hellseher March 23, 2024, 9:03 p.m. UTC | #2
Hi,

I've pushed 2 patches as fd579def37..68455ddf4b to master.

As the whole modules contains just 3 packages so I've applied some
refactoring:

- 28bc0e870b * gnu: magic-wormhole: Fix home page.
- edf7bd05e1 * gnu: magic-wormhole-transit-relay: Remove some native inputs.
- 7c11136764 * gnu: magic-wormhole-transit-relay: Fix indentation.
- b877fead3b * gnu: magic-wormhole-mailbox-server: Fix indentation.
- 8444c7b0dc * gnu: magic-wormhole: Limit amount of loaded symbols.
- 70386806e1 * gnu: magic-wormhole-transit-relay: Simplify package.
- 9972487417 * gnu: magic-wormhole-mailbox-server: Simplify package.
- 3b43d01c61 * gnu: magic-wormhole: Add licenses prefix.
- d72fe75367 * gnu: magic-wormhole: Fix indentation.
- fb667a7a8a * gnu: magic-wormhole: Simplify package.

Thanks,
Oleg
diff mbox series

Patch

diff --git a/gnu/packages/magic-wormhole.scm b/gnu/packages/magic-wormhole.scm
index 86a8013aa1..3b02426cd9 100644
--- a/gnu/packages/magic-wormhole.scm
+++ b/gnu/packages/magic-wormhole.scm
@@ -1,5 +1,7 @@ 
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2019 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2024 normally_js <normally_js@posteo.net>
+
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -20,6 +22,7 @@  (define-module (gnu packages magic-wormhole)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix licenses)
+  #:use-module (guix gexp)
   #:use-module (guix build-system python)
   #:use-module (gnu packages check)
   #:use-module (gnu packages python-check)
@@ -106,26 +109,27 @@  (define-public magic-wormhole-transit-relay
 (define-public magic-wormhole
   (package
     (name "magic-wormhole")
-    (version "0.12.0")
+    (version "0.13.0")
     (source
       (origin
         (method url-fetch)
         (uri (pypi-uri "magic-wormhole" version))
         (sha256
          (base32
-          "0q41j99718y7m95zg1vaybnsp31lp6lhyqkbv4yqz5ys6jixh3qv"))))
+          "05hm5pnrxli69a28h3pbgx6s6pwy8279l506kha7y3i7hs1dcfxc"))))
     (build-system python-build-system)
     (arguments
-     '(#:phases
-       (modify-phases %standard-phases
-         ;; XXX I can't figure out how to build the docs properly.
-         ;; https://debbugs.gnu.org/cgi/bugreport.cgi?bug=34515#101
-         (add-after 'install 'install-docs
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out"))
-                    (man (string-append out "/share/man/man1")))
-               (install-file "docs/wormhole.1" man))
-             #t)))))
+     (list
+      #:tests? #f ; Tests fail due to issue unrelated to dependencies.
+      #:phases
+      #~(modify-phases %standard-phases
+          ;; XXX I can't figure out how to build the docs properly.
+          ;; https://debbugs.gnu.org/cgi/bugreport.cgi?bug=34515#101
+          (add-after 'install 'install-docs
+            (lambda* (#:key outputs #:allow-other-keys)
+              (let* ((out (assoc-ref outputs "out"))
+                     (man (string-append out "/share/man/man1")))
+                (install-file "docs/wormhole.1" man)))))))
     (native-inputs
      (list python-mock
            ;; XXX These are required for the test suite but end up being referenced