diff mbox series

[bug#46792] gnu: guile-curl: Update to 0.9.

Message ID 2e1d97cc4baaad39ff33db070b1b47779182d9a2.1614340296.git.public@yoctocell.xyz
State Accepted
Headers show
Series [bug#46792] gnu: guile-curl: Update to 0.9. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Xinglu Chen Feb. 26, 2021, 11:52 a.m. UTC
* gnu/packages/curl.scm (guile-curl): Update to 0.9.
[#:phases]: Update path to module.
---
 gnu/packages/curl.scm | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)


base-commit: 099026df5ba6443a9291e8f9d91ccacfdce2f00d

Comments

Léo Le Bouter Feb. 26, 2021, 1:27 p.m. UTC | #1
Hello!

Could you use this package update with some software? GNU Guix does not
have any package that actually uses it.

Once I have a bit more assurance that this works correctly when used,
LGTM!

Thank you!
Xinglu Chen Feb. 26, 2021, 2:27 p.m. UTC | #2
On Fri, Feb 26 2021, Léo Le Bouter via Guix-patches via wrote:

> Hello!
>
> Could you use this package update with some software? GNU Guix does not
> have any package that actually uses it.
>
> Once I have a bit more assurance that this works correctly when used,
> LGTM!

I tried one of their example files and it worked as expected.

#+begin_src scheme
(use-modules (curl))

(define handle (curl-easy-init))
(curl-easy-setopt handle 'url "http://www.gnu.org")
(display (curl-easy-perform handle))
#+end_src
Ludovic Courtès March 11, 2021, 10:24 p.m. UTC | #3
Hi,

Xinglu Chen <public@yoctocell.xyz> skribis:

> * gnu/packages/curl.scm (guile-curl): Update to 0.9.
> [#:phases]: Update path to module.

Applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index 52c2be2f80..730676875c 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -198,14 +198,14 @@  not offer a replacement for libcurl.")
 (define-public guile-curl
   (package
    (name "guile-curl")
-   (version "0.7")
+   (version "0.9")
    (source (origin
             (method url-fetch)
             (uri (string-append "http://www.lonelycactus.com/tarball/"
                                 "guile_curl-" version ".tar.gz"))
             (sha256
              (base32
-              "1zk0ijx6bj212k0j0ma84cpvpvn0x6raaxnby3wdx3w4wnhnscn7"))))
+              "0y7wfhilfm6vzs0wyifrrc2pj9nsxfas905c7qa5cw4i6s74ypmi"))))
    (build-system gnu-build-system)
    (arguments
     `(#:modules (((guix build guile-build-system)
@@ -230,7 +230,7 @@  not offer a replacement for libcurl.")
       (modify-phases %standard-phases
         (add-after 'unpack 'patch-undefined-references
           (lambda* _
-            (substitute* "src/curl.scm"
+            (substitute* "module/curl.scm"
               ;; The following #defines are missing from our curl package
               ;; and therefore result in the evaluation of undefined symbols.
               ((",CURLOPT_HAPROXYPROTOCOL") "#f")