diff mbox series

[bug#38933] gnu: Add gnome-online-miners

Message ID 2e1c87509c6308e83bf5c2c6b9dad5288d4d7bb7.camel@disroot.org
State Accepted
Headers show
Series [bug#38933] gnu: Add gnome-online-miners | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Raghav Gururajan Jan. 6, 2020, 5:24 a.m. UTC
Hello Danny!

> Missing synopsis and description.

Please find the revised patch attached with this email.

Regards,
RG.

Comments

Danny Milosavljevic Jan. 9, 2020, 1:59 p.m. UTC | #1
Hi Raghav,

libgfbgraph is missing.

Please try to build the packages before sending them for inclusion.

BR,
   Danny
Raghav Gururajan Jan. 9, 2020, 2:02 p.m. UTC | #2
> libgfbgraph is missing.

It was supposed to be ("libgfbgraph" ,gfbgraph). I accidentally
mistyped when I was revising the package definition.

> Please try to build the packages before sending them for inclusion.

I did. It is a typo. I will send the corrected patch now. :-)

Regards,
RG.
diff mbox series

Patch

From 0371502b059e7e8bc3c9697707476364f5bc44d5 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Mon, 6 Jan 2020 00:21:11 -0500
Subject: [PATCH] gnu: Add gnome-online-miners.

* gnu/packages/gnome.scm (gnome-online-miners): New variable.
---
 gnu/packages/gnome.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index ec06e6d4d2..d53c123729 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -246,6 +246,38 @@  Desktop.  It is designed to be as simple as possible and has some unique
 features to enable users to create their discs easily and quickly.")
     (license license:gpl2+)))
 
+(define-public gnome-online-miners
+  (package
+    (name "gnome-online-miners")
+    (version "3.30.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://gnome/sources/" name "/"
+                                  (version-major+minor version) "/"
+                                  name "-" version ".tar.xz"))
+              (sha256
+               (base32
+                "1n2jz9i8a42zwxx5h8j2gdy6q1vyydh4vl00r0al7w8jzdh24p44"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("glib:bin" ,glib "bin")
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("gettext" ,gettext-minimal)
+       ("gnome-online-accounts" ,gnome-online-accounts)
+       ("grilo" ,grilo)
+       ("libgdata" ,libgdata)
+       ("gfbgraph" ,libgfbgraph)
+       ("libzapojit" ,libzapojit)
+       ("rest" ,rest)
+       ("tracker" ,tracker)))
+    (synopsis "Web Crawlers for GNOME")
+    (description "GNOME Online Miners provides a set of crawlers that
+go through your online content and index them locally in Tracker.
+It has miners for Facebook, Flickr, Google, ownCloud and SkyDrive.")
+    (home-page "https://wiki.gnome.org/Projects/GnomeOnlineMiners")
+    (license license:gpl2)))
+
 (define-public gnome-menus
   (package
     (name "gnome-menus")
-- 
2.24.1