From 0371502b059e7e8bc3c9697707476364f5bc44d5 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Mon, 6 Jan 2020 00:21:11 -0500
Subject: [PATCH] gnu: Add gnome-online-miners.
* gnu/packages/gnome.scm (gnome-online-miners): New variable.
---
gnu/packages/gnome.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)
@@ -246,6 +246,38 @@ Desktop. It is designed to be as simple as possible and has some unique
features to enable users to create their discs easily and quickly.")
(license license:gpl2+)))
+(define-public gnome-online-miners
+ (package
+ (name "gnome-online-miners")
+ (version "3.30.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1n2jz9i8a42zwxx5h8j2gdy6q1vyydh4vl00r0al7w8jzdh24p44"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("glib:bin" ,glib "bin")
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("gettext" ,gettext-minimal)
+ ("gnome-online-accounts" ,gnome-online-accounts)
+ ("grilo" ,grilo)
+ ("libgdata" ,libgdata)
+ ("gfbgraph" ,libgfbgraph)
+ ("libzapojit" ,libzapojit)
+ ("rest" ,rest)
+ ("tracker" ,tracker)))
+ (synopsis "Web Crawlers for GNOME")
+ (description "GNOME Online Miners provides a set of crawlers that
+go through your online content and index them locally in Tracker.
+It has miners for Facebook, Flickr, Google, ownCloud and SkyDrive.")
+ (home-page "https://wiki.gnome.org/Projects/GnomeOnlineMiners")
+ (license license:gpl2)))
+
(define-public gnome-menus
(package
(name "gnome-menus")
--
2.24.1
Hello Danny! > Missing synopsis and description. Please find the revised patch attached with this email. Regards, RG.