diff mbox series

[bug#62635,v2,2/3] gnu: geary: Add evolution-data-server as input.

Message ID 2e0a4a31add87dc634c89bb641b247e3171d4c14.1683487214.git.juli@incana.org
State New
Headers show
Series [bug#62635,v2,1/3] gnu: geary: Fix failing build. | expand

Commit Message

Juliana Sims May 7, 2023, 7:21 p.m. UTC
* gnu/packages/gnome.scm (geary) [inputs]: Add evolution-data-server.
---
 gnu/packages/gnome.scm | 1 +
 1 file changed, 1 insertion(+)

Comments

Liliana Marie Prikler May 7, 2023, 7:44 p.m. UTC | #1
Hi Juliana,

Am Sonntag, dem 07.05.2023 um 15:21 -0400 schrieb Juliana Sims:
> * gnu/packages/gnome.scm (geary) [inputs]: Add evolution-data-server.
> ---
>  gnu/packages/gnome.scm | 1 +
>  1 file changed, 1 insertion(+)
> 
> diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
> index 4c1d197e56..bc439619cd 100644
> --- a/gnu/packages/gnome.scm
> +++ b/gnu/packages/gnome.scm
> @@ -12344,6 +12344,7 @@ (define-public geary
>                        (setenv "DISPLAY" ":1"))))))
>      (inputs
>       (list enchant
> +           evolution-data-server
>             folks-with-libsoup2
>             gcr
>             glib
Possibly stupid question: Don't you need evolution-data-server to build
geary?  If so, this patch would need to be squashed on top of the
preceding one.

Cheers
Juliana Sims May 7, 2023, 9:10 p.m. UTC | #2
Hi,

Le 7 mai 2023 15:44:22 GMT-04:00, Liliana Marie Prikler <liliana.prikler@gmail.com> a écrit :
>Hi Juliana,
>
>Possibly stupid question:

No such thing :)

>Don't you need evolution-data-server to build
>geary?  If so, this patch would need to be squashed on top of the
>preceding one.

Interestingly, evolution-data-server seems to be a runtime-only dependency. I discovered this when I first installed Geary and found it would not launch - I only figured out the issue because a Debian developer friend had apparently run into the error message it threw and knew the cause. As far as I can tell, not even the Geary git repository itself makes any mention of this - perhaps because it's considered a core part of GNOME? I couldn't say. Regardless, the package does in fact build fine without evolution-data-server.

- Juli
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 4c1d197e56..bc439619cd 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -12344,6 +12344,7 @@  (define-public geary
                       (setenv "DISPLAY" ":1"))))))
     (inputs
      (list enchant
+           evolution-data-server
            folks-with-libsoup2
            gcr
            glib