diff mbox series

[bug#69001] gnu: Add dbg-macro.

Message ID 2df0e5cd9e2c955fadad22157d45dedfa88f719e.1707493900.git.paul@apatience.com
State New
Headers show
Series [bug#69001] gnu: Add dbg-macro. | expand

Commit Message

Paul A. Patience Feb. 9, 2024, 3:52 p.m. UTC
* gnu/packages/cpp.scm (dbg-macro): New variable.

Change-Id: If6c6cc5d3a309ee2f8987a1a3903069e29b6fdb0
---
 gnu/packages/cpp.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)


base-commit: 570ef13a87bb54d3410c431700ba78316a2641e2
diff mbox series

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 62a1923571..575bef895e 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -3048,3 +3048,37 @@  (define-public tl-optional
 the std::optional for C++11/14/17, with support for monadic operations added in
 C++23.")
     (license license:cc0)))
+
+(define-public dbg-macro
+  (package
+    (name "dbg-macro")
+    (version "0.5.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/sharkdp/dbg-macro")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "03nkvvy32rf00wwbx1hcv4k4kskvwp6sghqj4hdxr00wr7bgg4y2"))
+       (modules '((guix build utils)))
+       ;; Remove bundled Catch2.
+       (snippet #~(delete-file-recursively "tests/Catch2"))))
+    (build-system cmake-build-system)
+    (arguments
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (add-after 'unpack 'patch-cmake-test
+                 (lambda _
+                   (substitute* "CMakeLists.txt"
+                     (("add_subdirectory\\(tests/Catch2\\)")
+                      "find_package(Catch2 REQUIRED)")
+                     (("^ *list\\(APPEND CMAKE_MODULE_PATH .*\\btests/Catch2\\b.*")
+                      "")))))))
+    (native-inputs (list catch2))
+    (home-page "https://github.com/sharkdp/dbg-macro")
+    (synopsis "@code{dbg(…)} macro for @code{printf}-style debugging in C++")
+    (description "@code{dbg(…)} is a header-only implementation of a same-named
+macro which facilitates @code{printf}-style debugging in C++.")
+    (license license:expat)))