diff mbox series

[bug#72844,3/4] gnu: Add go-github-com-ipfs-go-bitfield.

Message ID 2dd821b4816a9f789d93ffe9335e187c48f04881.1724792671.git.poptsov.artyom@gmail.com
State New
Headers show
Series gnu: kubo: Add some direct and indirect dependencies. | expand

Commit Message

Artyom V. Poptsov Aug. 27, 2024, 9:09 p.m. UTC
* gnu/packages/golang-xyz.scm (go-github-com-ipfs-go-bitfield): New variable.

Change-Id: I95e627fb5f4dfcca5e4b70e753b544b4965b96c2
---
 gnu/packages/golang-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 796341a66b..056680afcf 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -3362,6 +3362,31 @@  (define-public go-github-com-itchyny-timefmt-go
 time strings.")
     (license license:expat)))
 
+(define-public go-github-com-ipfs-go-bitfield
+  (package
+    (name "go-github-com-ipfs-go-bitfield")
+    (version "1.1.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/ipfs/go-bitfield")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1zhgwdg2kizhk0hb9q5p0pwrwldd2pacz8l1pnapxh6qm3fqs663"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/ipfs/go-bitfield"))
+    (home-page "https://github.com/ipfs/go-bitfield")
+    (synopsis "Golang bitfield package")
+    (description
+     "@code{go-bitfield} is a simple bitfield package that's about 2-3x faster than
+using @code{big.Int} from the standard library.  It also has a better interface (and,
+e.g., supports counting ones).")
+    (license (list license:expat license:asl2.0))))
+
 (define-public go-github-com-jbenet-go-random
   (package
     (name "go-github-com-jbenet-go-random")