diff mbox series

[bug#71834] gnu: Add emacs-meyvn

Message ID 2dbf0c10e3cc313e3bc983611bd8036c3bcf4e1b.1719619608.git.daniel.szmulewicz@gmail.com
State New
Headers show
Series [bug#71834] gnu: Add emacs-meyvn | expand

Commit Message

Daniel Szmulewicz June 29, 2024, 12:12 a.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-meyvn): New variable.

Change-Id: I6a440e6917c77e098cc9101cba7dd14942b93c5b
---
 gnu/packages/emacs-xyz.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)


base-commit: 385fb14f6482a955fbef4d4b21fccb3473beddd8

Comments

Andreas Enge June 30, 2024, 8:08 p.m. UTC | #1
This seems to be a duplicate of #71842, closing.

Andreas
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 903c22bbcb..40c5cd8538 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -142,6 +142,8 @@ 
 ;;; Copyright © 2024 Wilko Meyer <w@wmeyer.eu>
 ;;; Copyright © 2024 Noé Lopez <noelopez@free.fr>
 ;;; Copyright © 2024 gemmaro <gemmaro.dev@gmail.com>
+;;; Copyright © 2024 Daniel Szmulewicz <daniel.szmulewicz@gmail.com>
+
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1860,6 +1862,36 @@  (define-public emacs-mct
     (license (list license:gpl3+
                    license:fdl1.3+)))) ; GFDLv1.3+ for the manual
 
+(define-public emacs-meyvn
+  (package
+    (name "emacs-meyvn")
+    (version "20231213.230")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/danielsz/meyvn-el.git")
+             (commit "3afb0a4283afd4f63ef7fdd48eb5da972421fd7a")))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1flxvaj8j5kg4r0cvns8z1xixgvsavq1i27z28j97m8dmndihihf"))))
+    (build-system emacs-build-system)
+    (propagated-inputs (list emacs-cider
+                             emacs-projectile
+                             emacs-s
+                             emacs-dash
+                             emacs-parseedn
+                             emacs-parseclj
+                             emacs-geiser))
+    (home-page "https://github.com/danielsz/meyvn-el")
+    (synopsis "Meyvn client")
+    (description
+     "This package provides an Emacs client for the Meyvn build tool,
+https://meyvn.org To use this package, simply add the following code snippet in
+your init.el Changelog: Kawa Geiser support. (add-hook cider-mode-hook
+#'meyvn-setup).")
+    (license license:gpl3+)))
+
 (define-public emacs-fzf
   (let ((commit "21912ebc7e1084aa88c9d8b7715e782a3978ed23")
         (revision "0"))