diff mbox series

[bug#70252,1/4] gnu: opencl-headers, opencl-clhpp and opencl-icd-loader: Update to 2023.12.14.

Message ID 2db9669b9140789d3d01894dd87e73e3c6bb550f.1712473796.git.a.r.draidi@redscript.org
State New
Headers show
Series Update and restyle Khronos OpenCL packages | expand

Commit Message

Ahmad Draidi April 7, 2024, 8:09 a.m. UTC
These packages should be updated together.

* gnu/packages/opencl.scm (opencl-headers): Update to 2023.12.14.
[home-page]: Update URL.
(opencl-clhpp): Update to 2023.12.14.
(opencl-icd-loader): Update to 2023.12.14.
[source]: Update origin URI to fix lint.

Change-Id: I56ee52a6df3fbbe7aa44743f09b28b07e5442b9f
---
 gnu/packages/opencl.scm | 16 ++++++++--------
 1 file changed, 8 insertions(+), 8 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/opencl.scm b/gnu/packages/opencl.scm
index 036834f567..f265d983f0 100644
--- a/gnu/packages/opencl.scm
+++ b/gnu/packages/opencl.scm
@@ -55,7 +55,7 @@  (define-module (gnu packages opencl)
 (define-public opencl-headers
   (package
     (name "opencl-headers")
-    (version "2023.02.06")
+    (version "2023.12.14")
     (source
       (origin
         (method git-fetch)
@@ -64,13 +64,13 @@  (define-public opencl-headers
               (commit (string-append "v" version))))
         (file-name (git-file-name name version))
         (sha256
-         (base32 "1jxpx15gwxc6i7vp64xlzcxf57nl0qnaiip6jyr0j7iji47dm404"))))
+         (base32 "13a5zv0nvjp66sswm6zdakmfjxp7536wplampbx9fa6q7i14lpy0"))))
     (build-system cmake-build-system)
     (arguments `(#:tests? #f)) ; Not enabled during build.
     (synopsis "The Khronos OpenCL headers")
     (description
      "This package provides the C headers by Khronos for OpenCL programming.")
-    (home-page "https://www.khronos.org/registry/OpenCL/")
+    (home-page "https://registry.khronos.org/OpenCL/")
     (license license:asl2.0)))
 
 (define (make-opencl-headers major-version subversion)
@@ -96,7 +96,7 @@  (define-public opencl-headers-1.0
 (define-public opencl-clhpp
   (package
     (name "opencl-clhpp")
-    (version "2023.02.06")
+    (version "2023.12.14")
     (source
      (origin
        (method git-fetch)
@@ -104,7 +104,7 @@  (define-public opencl-clhpp
              (url "https://github.com/KhronosGroup/OpenCL-CLHPP")
              (commit (string-append "v" version))))
        (sha256
-        (base32 "1m3v5apjv3qagym32xqg38pq6i8j5d8svz11clsx408nrlyngrj0"))
+        (base32 "0hagizc636wfcfmdl0f4bghprjnz1dba2kvkwh2ysj485n8lmjh4"))
        (file-name (git-file-name name version))))
     (native-inputs
      `(("python" ,python-wrapper)))
@@ -125,16 +125,16 @@  (define-public opencl-clhpp
 (define-public opencl-icd-loader
   (package
     (name "opencl-icd-loader")
-    (version "2023.02.06")
+    (version "2023.12.14")
     (source (origin
               (method git-fetch)
               (uri (git-reference
-                    (url "https://github.com/KhronosGroup/OpenCL-ICD-Loader.git")
+                    (url "https://github.com/KhronosGroup/OpenCL-ICD-Loader")
                     (commit (string-append "v" version))))
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1cmbcm6bz6kfvr0dy9hzf2vgfwcz8gbm8rxspqqpva6z74dz0qxr"))))
+                "03xjkfb98paya5h18qsqdf3gqp063iblgbgahcfji9q91i0b327z"))))
     (build-system cmake-build-system)
     (arguments `(#:tests? #f)) ; Tests need stub loader setup.
     (native-search-paths