diff mbox series

[bug#68908] gnu: Add ocaml-toml.

Message ID 2d9d01dbdc500dbe07618c172645e99e3d2a62fa.1706972151.git.soeren@soeren-tempel.net
State New
Headers show
Series [bug#68908] gnu: Add ocaml-toml. | expand

Commit Message

Sören Tempel Feb. 3, 2024, 3:11 p.m. UTC
From: Sören Tempel <soeren@soeren-tempel.net>

* gnu/packages/ocaml.scm (ocaml-toml): New variable.

Signed-off-by: Sören Tempel <soeren@soeren-tempel.net>
---
 gnu/packages/ocaml.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index e9ada32bde..fcb45793aa 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2078,6 +2078,29 @@  (define-public ocaml-iso8601
     (home-page "https://github.com/ocaml-community/ISO8601.ml")
     (license license:expat)))
 
+(define-public ocaml-toml
+  (package
+    (name "ocaml-toml")
+    (version "7.1.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/ocaml-toml/To.ml")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0z2873mj3i6h9cg8zlkipcjab8jympa4c4avhk4l04755qzphkds"))))
+    (build-system dune-build-system)
+    (propagated-inputs (list ocaml-base ocaml-mdx ocaml-menhir ocaml-iso8601))
+    (synopsis "TOML library for OCaml")
+    (description
+     "This package provides an OCaml library for interacting with files
+in the @acronym{TOML, Tom's Obvious Minimal Language} format.  Specifically,
+it provides parser, a serializer, and a pretty printer.")
+    (home-page "https://github.com/ocaml-toml/To.ml")
+    (license license:expat)))
+
 (define-public ocaml-topkg
   (package
     (name "ocaml-topkg")