[bug#75099,rust-team] gnu: rust-indoc-impl-0.3: Do not inherit.
Commit Message
* gnu/packages/crates-io.scm (rust-indoc-impl-0.3): Do not inherit.
[home-page, license]: Add.
[version, source]: Update to 0.3.7.
[arguments]: Build. Remove rust-proc-macro-hack-0.5.
Change-Id: Ie57baea4c388a32e00443c39abe80119786b14f8
---
gnu/packages/crates-io.scm | 15 +++++++--------
1 file changed, 7 insertions(+), 8 deletions(-)
base-commit: 32ab343e03e998ada27c063ef7d8a00aa88436dd
Comments
This one had some issues. rust-indoc-0.3 wants rust-indoc-0.3.6
specifically, so I had to downgrade it back to 0.3.6. Also
proc-macro-hack is needed for building the package, it just isn't listed
with cargo import for some reason. I made the changes and applied it to
the rust-team branch, and followed up with building rust-indoc-0.3.
@@ -37292,29 +37292,28 @@ (define-public rust-indoc-0.3
(define-public rust-indoc-impl-0.3
(package
- (inherit rust-indoc-0.3)
(name "rust-indoc-impl")
- (version "0.3.6")
+ (version "0.3.7")
(source
(origin
(method url-fetch)
(uri (crate-uri "indoc-impl" version))
(file-name (string-append "rust-indoc-impl-" version ".tar.gz"))
(sha256
- (base32 "1w58yg249kmzsn75kcj34qaxqh839l1hsaj3bzggy3q03wb6s16f"))))
+ (base32 "0m0s0klnyjprfw6q6rnz6rl5hyfkjiv3md30s15v487wkcby05vi"))))
(build-system cargo-build-system)
(arguments
- `(#:skip-build? #t
- #:cargo-inputs
- (("rust-proc-macro-hack" ,rust-proc-macro-hack-0.5)
- ("rust-proc-macro2" ,rust-proc-macro2-1)
+ `(#:cargo-inputs
+ (("rust-proc-macro2" ,rust-proc-macro2-1)
("rust-quote" ,rust-quote-1)
("rust-syn" ,rust-syn-1)
("rust-unindent" ,rust-unindent-0.1))))
+ (home-page "https://github.com/dtolnay/indoc")
(synopsis "Macros for @code{rust-indoc}")
(description
"This package provides macros for use with the @code{rust-indoc}
-package. It is obsolete for indoc versions > 1.")))
+package. It is obsolete for indoc versions > 1.")
+ (license (list license:expat license:asl2.0))))
(define-public rust-infer-0.15
(package