diff mbox series

[bug#72211,6/7] gnu: Add go-github-com-ipfs-go-ipfs-blockstore.

Message ID 2d77f6cf408e022d9fe2300a32c19e87d98ced2e.1721486984.git.poptsov.artyom@gmail.com
State New
Headers show
Series gnu: kubo: Unbundle go-github-com-ipfs-go-metrics-interface. | expand

Commit Message

Artyom V. Poptsov July 20, 2024, 3:33 p.m. UTC
* gnu/packages/ipfs.scm (go-github-com-ipfs-go-ipfs-blockstore): New variable.

Change-Id: I75b885ec55b5bd8ae274a4832d421bf2de696314
---
 gnu/packages/ipfs.scm | 38 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 38 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ipfs.scm b/gnu/packages/ipfs.scm
index 21440b1948..25d3d6212f 100644
--- a/gnu/packages/ipfs.scm
+++ b/gnu/packages/ipfs.scm
@@ -98,6 +98,44 @@  (define-public go-github-com-ipfs-go-block-format
 corresponding to the block.")
     (license license:expat)))
 
+(define-public go-github-com-ipfs-go-ipfs-blockstore
+  (package
+    (name "go-github-com-ipfs-go-ipfs-blockstore")
+    (version "1.3.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/ipfs/go-ipfs-blockstore")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1a3a0fm8k8njdlq2w795qff01piadjfp6r5r2hww69fxqsplln9l"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:go go-1.21
+      #:import-path "github.com/ipfs/go-ipfs-blockstore"))
+    (propagated-inputs
+     (list go-github-com-hashicorp-golang-lru
+           go-github-com-ipfs-bbloom
+           go-github-com-ipfs-go-block-format
+           go-github-com-ipfs-go-cid
+           go-github-com-ipfs-go-datastore
+           go-github-com-ipfs-go-ipfs-ds-help
+           go-github-com-ipfs-go-ipfs-util
+           go-github-com-ipfs-go-ipld-format
+           go-github-com-ipfs-go-log
+           go-github-com-ipfs-go-metrics-interface
+           go-github-com-multiformats-go-multihash
+           go-go-uber-org-atomic))
+    (home-page "https://github.com/ipfs/go-ipfs-blockstore")
+    (synopsis "Caching wrapper over a IPFS datastore")
+    (description
+     "@code{go-ipfs-blockstore} implements a thin wrapper over an IPFS datastore,
+giving a clean interface for getting and putting block objects.")
+    (license license:expat)))
+
 (define-public go-github-com-ipfs-go-ipfs-blocksutil
   ;; Use the latest commit from the "master" branch to fix the build with go-1.21.
   (let ((commit "ce0497f5ee55c479db98905aec8ff56c27aad2a2")