diff mbox series

[bug#56601] gnu: Add texlive-pgfgantt.

Message ID 2d22922c8edaccb5bbc8f414c6502d0f190d524e.1657981653.git.me@fabionatali.com
State Accepted
Headers show
Series [bug#56601] gnu: Add texlive-pgfgantt. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Fabio Natali July 16, 2022, 2:28 p.m. UTC
---
 gnu/packages/tex.scm | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)


base-commit: 4ce7f1fb24a111f3e92d5b889d1271bebf109d09
prerequisite-patch-id: 15fbd940ff2c4d720e5400d6413ffbfdf01ead36
prerequisite-patch-id: 4b09fce4186da53607ac1503a21a16c410eb0287
diff mbox series

Patch

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index cb40f3b549..2c6c961879 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11067,3 +11067,20 @@  (define-public texlive-setspace
 doublespacing.  Alternatively the spacing can be changed as required with the
 \\singlespacing, \\onehalfspacing, and \\doublespacing commands.  Other size
 spacings also available.")))
+
+(define-public texlive-pgfgantt
+  (package
+    (inherit
+     (simple-texlive-package
+      "texlive-pgfgantt"
+      (list "doc/latex/pgfgantt/" "source/latex/pgfgantt/" "tex/latex/pgfgantt/")
+      (base32 "0bm034iizk4sd7p5x7vkj7v57dc0bf2lswpsb32s4qlg4s7h6jqz")
+      #:trivial? #t))
+    (propagated-inputs (list texlive-pgf))
+    (home-page "https://ctan.org/graphics/pgf/contrib/pgfgantt")
+    (synopsis "Draw Gantt charts with TikZ")
+    (description
+     "The package provides an environment for drawing Gantt charts that contain
+various elements (titles, bars, milestones, groups and links).  Several keys
+customize the appearance of the chart elements.")
+    (license license:lppl1.3+)))