diff mbox series

[bug#68099,2/2] gnu: cl-flexi-streams: Improve package style.

Message ID 2ce7ac4df90a7ecb34793a21c8b6f29a14820060.1703852000.git.paul@apatience.com
State New
Headers show
Series [bug#68099,1/2] gnu: cl-flexi-streams: Update to 1.0.19-0.74a1027. | expand

Commit Message

Paul A. Patience Dec. 29, 2023, 12:17 p.m. UTC
* gnu/packages/lisp-xyz.scm (sbcl-flexi-streams)[arguments]: Use
  G-expressions. Drop trailing #t in phases.
  [inputs]: Remove labels.

Change-Id: I4aae98985435203006384906a0b28c798e3b9740
---
 gnu/packages/lisp-xyz.scm | 14 +++++++-------
 1 file changed, 7 insertions(+), 7 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index e82b33eb92..be49bac2fd 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -1376,13 +1376,13 @@  (define-public sbcl-flexi-streams
           (base32 "04azqvz11s8dngy49bjl19hrfn0ip1b7m0szm4hlppq364msil7b"))))
       (build-system asdf-build-system/sbcl)
       (arguments
-       `(#:phases
-         (modify-phases %standard-phases
-           (add-after 'unpack 'make-git-checkout-writable
-             (lambda _
-               (for-each make-file-writable (find-files "."))
-               #t)))))
-      (inputs `(("trivial-gray-streams" ,sbcl-trivial-gray-streams)))
+       (list #:phases
+             #~(modify-phases %standard-phases
+                 (add-after 'unpack 'make-git-checkout-writable
+                   (lambda _
+                     (for-each make-file-writable (find-files ".")))))))
+      (inputs
+       (list sbcl-trivial-gray-streams))
       (synopsis "Implementation of virtual bivalent streams for Common Lisp")
       (description "Flexi-streams is an implementation of \"virtual\" bivalent
 streams that can be layered atop real binary or bivalent streams and that can